View Single Post
It sounds to me like it is the auto-locking keychain.

In my experience, this has to do with how long the _keychain_ has gone unused, not how long the computer has been idle. I could be wrong, but that seems to match my experience.

You can check to see if it's got a timeout, and change the timeout, by launching Keychain Access (in /Applications/Utilities), selecting the "login" keychain, then choosing "Change Settings for Keychain 'login'" from the Edit menu. The resulting panel has a "Lock after X minutes of inactivity" setting.

Last edited by Andrew; 2009-03-02 at 12:57 PM.. Reason: Doing a bad job of proof-reading before posting