View Single Post
Starting a week or two ago, I started noticing pop-up ad windows behind a home page window. I figured I'd messed up my pop-up window blocker.

I just checked, and my Preferences for were set to my global default: Block pop-up windows only when not requested.

So I changed to Block pop-up windows always. The small ad windows are continuing to sneak behind the home page. Sigh.

-- Ward

[submitted as formal feedback]