View Single Post
Hi all,
First post, hoping anyone can assist.

Loving Omnifocus which I have for my mac and my iphone, but it is not without its quirks.
I have been on to support directly with regard to small attachments to tasks (plain text files & simple excel and PDF files > all well under 50 - 80kb). They told me if I embed the file instead of linking to it, it will show up as a read only file on my iPhone, which is fine by me. Once they told me how to embed I was set.
Now today, two major issues have cropped up after a few days of absolute sync bliss.

1 - Image attachments taken on the iPhone - Gone on Mac... but present on iPhone. Mac shows the file attachment icon on the far right, but there is no image file there to view when you expand it. Now, these images are, small, 480 x320 pixels, and were taken natively from within Omnifocus, so they are not too big, AND, they were visible clearly for days on my Macbook. I opened them in Preview just fine a bunch of times.
But today, nothing there. Like the database has somehow become corrupted?
For me, this is not good at all because I often create a task from an image using my iPhone and Omnifocus, and the text of said task is is simply "See image" or "Picture Task". The idea is to drop these in to the inbox and assign context et al at the sorting stage on the desktop.
Now I have about 10 similar task titles that are meaningless to me without the bloody image.
If they were gone on the iPhone i would, to put it simply, be screwed. Anyone know whats going on there? I don't want to inundate support directly with more questions, and I badly want this to work reliably.

2 - A bigger issue. Back to my embed files I mentioned at the top of this post. In Omnifocus for Mac, I have, attached, as an embedded file, a plain text document, attached to a task. Here is where I put my notes, I use the plain text file as it is linked to dropbox.
I was able to view the plain text file as a read only file on my iPhone. this worked for a few days fine.
I would amend the text file > Sync > review my amended notes in said text file (read-only) on the train home etc. I would get in to work, make more amendments on the desktop and sync again, review the read-only text attachment on my lunchbreak etc. After doing this for a few days, I dug in, and spent a good part of yesterday, amending a bunch of text files, saving and syncing.
Today however, ALL my changes and amendments in these plain text files from yesterday are gone. A good portion of a days work, just gone. They have reverted to an earlier state, like before yesterday or something. And they are not on my iPhone either.
Bottom line, sync screwed up royally here and I'm at a loss to explain it. This is an imperative function for me and if I cannot rely on it 1000% as one needs to do if this is a 'trusted bucket' I should go back to pen and paper.

Now, if you've gotten this far, thanks, I wanted to be as clear as I could be in the initial post, sorry if its a little long!

There's a good chance its user error. But it worked before, now it doesn't and I really need to know whats going on as I can't trust the system as it is.

Any advice appreciated!
Thanks in advance,