View Single Post
I had forgotten that maybe I needed some emails in the list of allowed emails. Once I read your post I added some emails and now all is working.

More details follow:
I had this all working just fine. Then messages that were supposed to be processed were simply ending up in my trash without also being sent to the omnifocus inbox. I had a look at the script and found that it was failing when it was checking the allowed email senders and found no match. I added the 2 email addresses from which I would send and voila it worked.

Take yourself to omnifocus::preferences::mail:allowedfromaddresses and add the addresses you wish to allow to use this feature.

At first I tried the following:
1. turn off the add mail rule to create omnifocus actions in omnifocus::preferences::mail. then turned it back on. What this does is it removes the action from, restarts then re-adds the action to and restarts That was not sufficient.

2. I turned off and turned on clip-o-tron support in omnifocus::preferences:clippings -that was also insufficient, but, in doing so re-read the note on that settings UI and now I know the keyboard shortcut -which I had forgot.

3. I add some log instructions to the script itself and found out where it was prematurely exiting the script. -that's when I realized I needed to add some emails to the list of allowed emails.

Okay, so this was working and then it stopped. It took a bit of work back and forth with the OF ninja and some work on my own to solve this -for my particular case. I can only think that something happened when I 1. upgraded from OS X 10.6. to 10.7 and/or when an update to OF appeared shortly after 10.7 was released -something in there must have wiped out my list of allowed emails.