View Single Post
I love you, Apple...
It is impossible to sync via WebDAV in OS X Lion Server. You will receive errors 502, 403 during the MOVE transaction.

I found the solution. But I can't guarantee the effect - maybe you should reconfigure Apache every time after upgrade/etc.
OS: OS X Lion Server, 10.7.0, 10.7.2 beta.
$ cd /etc/apache2
$ sudo vim httpd_webdavsharing.conf
After </Location> add these lines:
DavLockDB /var/tmp/DavLock
Alias /secretplace /Users/username/Sync
<Directory /Users/username/Sync>
AuthType Digest
AuthName "UserWebDAV Gateway"
Require valid-user

Create Sync dir and grant permission:
$ mkdir /Users/username/Sync
$ chmod 777 /Users/username/Sync

Restart Apache
$ sudo apachectl stop
$ sudo apachectl start

In the WebDAV Sync preferences setup URL:
https /secretplace/

Press Sync and prey.

It is not enough to change permissions for "default" DAV Share directory, I found only described method is working...

But be warned - if your devices will stop sync after update, server restart and other similar action - repeat.