View Single Post
Try option-clicking on the Line Tool, then unchecking the Allow connections to other objects box in the Connections section of the Properties inspector. Lines you create should no longer attach themselves to objects until you undo that setting.

See the "Inspect a tool" portion of the built-in help for "Changing how tools work with the Drawing Tools preferences" for more information.