View Single Post

Try this:

-Right-click or control-click on the link to save the .ics file to your desktop.

-Right-click or control-click on the .ics file and select "Get Info".

-There should an option named "Open With:". Click on the drop-down menu and select "Other", then select "iCal" from your Applications folder.

-Click the "Change All..." button to set iCal as the default application for .ics files.

That should do it. Let me know how it works for you. :)