View Single Post
Originally Posted by coldrick View Post
Sorry, I wasn't being clear. My sync server is on the LAN, not the WAN. So the problem is at least similar to Gerd's. I was trying to show that other iPhone apps have no problem going thru a proxy.

Corrected below - my bad:

For my laptop syncing to the desktop sync server, if I turn off the https: proxy, the sync works. If it's on, it fails. Note that the network pref has

"localhost,," in the "Bypass proxy . . .". All network addresses are 10.0.5.x

The console error message if I don't turn off https:// proxying is below:

12/10/09 12:13:23 PM, 12 October 2009 OmniFocus[10055] sync terminated with error: {
code = 310;
domain = kCFErrorDomainCFNetwork;
userInfo = {
NSErrorFailingURLKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSErrorFailingURLStringKey = "https://bigmac.local:49162/OmniFocus.ofocus";
NSLocalizedDescription = "There was a problem communicating with the secure web proxy server (HTTPS).";
NSLocalizedRecoverySuggestion = "To change your proxy settings, open Network preferences, click Advanced, and then click Proxies. For help with this problem, contact your system administrator.";
Sometimes we overlook the fact that we have at hand and it's well when we learn from our mistakes .