View Single Post
Here's the solution to the puzzle, right from the OmniFocus manual:

By default, OmniFocus creates links to the files you attach, rather than adding the files to your OmniFocus database. This keeps your database from growing needlessly (which is especially important if you are syncing your data), but the link will break if you delete the file or put it somewhere OmniFocus canít find it. To make OmniFocus copy a file into its database for safekeeping, hold the Option key as you drop the file, or select Embed the file in the document in the Attach File dialog.


And that is apparently what you have to do: force OmniFocus to make a copy rather than a link. Problem is, it's not always completely apparent what's going on.

But if you're dragging and dropping, make sure you hold the Option key down while doing it (you'll see a "+" instead of the little black arrow that you would see for a link/alias). If you're using the Edit menu to attach, make sure you select "Embed the file in the document" (which is not the default).

If you're copying the file and then using paste to paste it in the comment, that seems to work...but I'm not sure. If you're dragging right into white space...well, again, I'm not sure.