View Single Post
If you've tried all the other tips here and are still having trouble, the first thing to do is try rebooting the application you're having trouble clipping from, then try again.

If that doesn't solve the issue, the next important thing to check and make sure the menu item for the OmniFocus clipping service is showing, and has your keyboard shortcut next to it.

To test this, select some text in the application you're having trouble clipping from, then choose
<name of the application> -> Services
from the menu bar.

If no submenu appears when you hover over the Services menu item, this application may not support the Services system at all. Firefox and Microsoft Office are examples of applications in this category. You'll want to email the developers and ask them to add Services support. (You may still be able to clip in other applications, of course.)

If a submenu appears, but you don't see an OmniFocus: Send to Inbox entry, you'll want to double-check these steps to make sure that the clipping service hasn't been turned off accidentally.

If a submenu and the OmniFocus entry both appear, but you don't see a keyboard shortcut in the menu item, then you'll want to check OmniFocus' clipping preferences pane. It's possible that the shortcut got disabled. (If the "reset" button in the clipping shortcut field was pressed, for example, or if the Reset button at the bottom was pressed.)

If a submenu appears, you see the OmniFocus entry, and it has a shortcut, the clipping service is set up correctly. Our code has registered the shortcut with the system and is ready to accept events that Mac OS X sends along.

If the shortcut still isn't working, that means we're not receiving those events for some reason. Keep reading for steps to use to figure out why the messages aren't making it to the service.

First, try the shortcut in several different applications; if it works in some of your applications, that means the other applications are using the shortcut you chose for their own purposes. You'll want to try a different shortcut that doesn't conflict with theirs.

If the shortcut never succeeds, the next thing to check is for a conflict with one of the other keyboard shortcuts enabled on your Mac. Open up Keyboard preferences and disable all the shortcuts by unchecking their boxes in the preference pane.

Everything from "Dashboard & Dock" to "Application Shortcuts" in the left-hand list needs to be selected, and everything in each of the sub-lists on the right must then be unchecked. Once that's done, re-check the box next to the OmniFocus service - it's in the "Text" subsection of the "Services" group.

Finally, re-start the application you're trying to clip from and try the shortcut again. Does it work? If so, you can re-enable the shortcuts you want to use on your Mac in System Preferences.

If you've tried all this and are still having trouble, please contact the support ninjas. Let them know what shortcuts you've tried, which apps (if any) they work in, and what version of the OS is installed on your Mac.

Last edited by Brian; 2010-01-26 at 02:28 PM.. Reason: add firefox/office info