View Single Post
Originally Posted by whpalmer4 View Post
I use no such software
OK, we should figure out what is happening in your case, then.

Does the SQL database still exist when you get this error? (For everyone else I've talked to, it had been removed or was unwritable.) If so, what happens when you try to access it from a Terminal window using the sqlite3 command?

Does this happen on all of your machines, or just one? Is there anything peculiar about that machine?

As for the "we can't fix it if we can't make it happen in the lab" argument … If the group mindset at Omni is truly that bugs which cannot be reproduced on demand are unfixable
It's sure a lot easier to fix things we can reproduce—but I don't know where you're getting the notion that we don't work on things we can't reproduce.

In fact, a significant portion of our engineering time (past and present) is spent trying to fix issues that we can't reproduce. (A recent example: since OmniFocus 2 launched we've spent a significant amount of that team's engineering effort trying to determine why OmniFocus 2 crashes on launch for some people who use Exchange calendars—a problem we still haven't been able to reproduce here, or it would likely already be solved.)

We do try to focus on doing work that will bring the most benefit to the most people. As far as I know your particular problem is unique (since everyone else's problem has been solved by repairing permissions or by not running other software which deletes our cache), so I apologize for it slipping through the cracks—and I do hope we can track it down.

As for "ethically sourced software"… I assume you did see how many builds went out between 11pm and 2am last night? And started up again at 7am this morning?