View Single Post
The most likely culprit here is that the first canvas of your document is somewhat complex, and Quick Look is taking a while to generate a preview when OmniGraffle is autosaving your file. To turn this off, uncheck the "Include Quick Look Preview" checkbox in the Document Inspector. (See attached screenshot.)

Also, if your Graffle file is on a network share of some sort, it would also contribute to a slow autosave process.

Does that help?
Attached Thumbnails
Click image for larger version

Name:	og5-quicklook.png
Views:	284
Size:	31.1 KB
ID:	1855