View Single Post
Running the initial sync, I got the error "The variable 'wholastpulled' is not defined". Scripts in the terminal window weren't working.

----------------------

Update: So, I didn't source my .bash_profile file (checked the instructions from Senor Pantelones which included that as a step).

Now push_files worked from my primary OF (which is on my host machine). And then SyncMirror worked to push and pull.

Note: I had to move my databases back to the default location. I'd moved them elsewhere thinking I'd be syncing with iDisk or a USB, but saw in .bash_profile that they expect the default location..

-----------------------

Next Update: Pull on my client didn't copy anything. It said "List empty". As a potentially useful bit of information, the "Mirrored" directory on my host computer is empty, though "Mirrors" has the folders "tide", my short hostname, and "WhoLastPulled"

Ok, found solution: more details from Senor P, I needed to create a directory in Mirrors for my client computer that I was pulling from.

SUCCESS!

Thanks for all these! Both OF and the syncmirror.

Last edited by frilliams; 2008-03-13 at 08:53 AM..