View Single Post
Everyone else no doubt knows this, but I just figured it out and maybe I can save someone else the confusion period in the future.

When text is pasted into a row, using ordinary Paste command, not only does the pasted text appear in the style of the "clipping" or copied text, but it creates a new style for subsequently added rows at that level and its children.
When I make a new row that is to the left of the one into which I originally pasted the text, then the overall style of the doc resumes.

To avoid this behavior, use Paste with Current Style, Opt-Shift-Command-V.

Maybe it is just me, but this seems backward. I'd like to have the option of choosing how this works, with the default being that the pasted material has its own style but does not affect the style of subsequently added lower rows.

For now I will try assigning an easier key stroke to Paste with Current Style.

Also, now that I knew what to search under, I found this addressed in a 2006 forum post, where Jacob offered advice including:

As for the outline you're trying to clean up, I think the thing to do is, (1) MAKE A COPY (in case this is bad advice I'm giving), (2) select all the rows in the outline and select "Clear Style" from the Format menu. This will (I think) clear away all the formatting except what's applied to the whole document. Then you can select "All Level 1 Rows" in the styles pallette at the bottom of the utility drawer and use the Inspectors to set the formatting of your top level rows, then select "All Level 2 Rows", etc. etc.
and also in 2006 moderator Derek M responded to this question

If I paste in some text that has it's own format, what is the easiest way to change it to the style of that row in my document. I'm not sure what "Clear style" is supposed to do, but that isn't it.

This can depend on a couple things. If you have 'Automatic Level Styles' on under the Format menu, then the pasted styles can be promoted depending on the content of your file when you paste. If you want to know more about this, let me know.

The Clear Style command will remove any local styles. If you have the auto level styles feature off, Clear Style should remove everything that was brought in by the paste.

If Clear Style doesn't work, then you need to highlight the text and use the Style Attributes inspector. In that inspector you'll see all the styles effecting that text. Click the 'x' to the right of each entry that you want to remove.

However, you can avoid all this if you use the other paste option 'Paste With Current Style' which will paste the clipboard data without any styling so it takes on the style of the row you're pasting to.
A long thread from 2006 on handling styles in OO is at
HTML Code:
I have not read all of the 4 pages of this thread yet but I have found at least one good tip,
from bashosfrog,

I pretty much ignore Styles view for mass changes and just use the Utilities panel. ie. Select "All Level 2 Rows" in the lower window (OO clicks into Styles View), then make changes in Inspector = all Level 2 rows changed as expected.

I don't really "get" Styles View either. Not for everyday use. But I haven't needed to use it in order to set up OO documents of stunning style :-)
And this thread showed me I am far from alone in having difficulty with how OO handles styles. I love what I can do with OO, don't get me wrong, it is just hard for me to figure out this aspect of the app. I am working my way through about 20 pages of the pdf manual that deal with style. Searching for "paste" and "pasting", though, gets no hits in the manual so it is possible that this business of having inherited styles introduced by pasting, is not addressed in the manual.