View Single Post
Originally Posted by Danoz View Post
I've recently been having difficulty with Curt's (awesome) Populate Template script.

I get an error message when it runs of "Can't get last paragraph of missing value" before it does anything.

I have tried with the last few versions, thinking it could be an issue peculiar to a new version, but it remains the same.

Today I quit OF, re-downloaded and re-installed a fresh version of the script.
I ran the script on one of my templates and lo, it worked (almost).

It started working, took all of my placeholder details and then began, but soon ended with an error of something to do with Can't set type of text to numbers (??? I think).
It did duplicate the project and I noticed it did populate the first entry, but no others.

Sorry for the sketchy details - I tried running the script again, to get the error message, but now I get my previous error message, and the script does not run at all - just like before.


The script still works for me in the latest build. The first error you're getting indicates that you don't have a note field in the project selected for duplicating, perhaps because you're trying to duplicate a duplicate which had its placeholders erased from the note? The other error was more likely "Can't set type of number to string". Do you have an action in your template that is just a number?

I should make the error checking in the script more robust. Could you send me the template you're having trouble with off-forum? (Easiest way is probably to display the template in OF, expand all, display all the notes, and take a screen shot. My email address is in the script instructions.)