View Single Post
Since you're getting "Method not allowed" despite setting "Dav On" for the appropriate <Directory> block, I wonder if there might be a <Limit> or <LimitExcept> directive somewhere in your Apache configuration which is restricting the PROPFIND method? Or perhaps there's something which is trying to offer a variant URL (possibly based on the requestor's language) that ends up redirecting to an index.html or index.php and the PROPFIND method isn't allowed for that? (Unfortunately, there are a lot of ways that WebDAV can be misconfigured, and it's hard to guess at which thing might be wrong from just a small excerpt of the configuration files.)

Unfortunately, even if you get this particular issue solved, I'm afraid we've found that OS X Server's stock WebDAV sharing setup is buggy on Mavericks: it sets up proxy servers for each user, and its proxying behavior isn't very robust. (One of the problems is that it rewrites URLs when redirecting to the proxy, but it's not very careful about how it rewrites them so it ends up mangling URLs which contain the share name anywhere in the path. One of the other problems is that the forwarding proxy server can end up reporting the wrong status code when there's any sort of timeout or other exception.)

We recently posted a support article for configuring Apache WebDAV sharing by hand on a Mavericks server, which we've posted at Configuring WebDAV for OmniPresence Sync. Following the instructions from that article should also work for setting up your own server to sync OmniFocus (or OmniPlan).