View Single Post
One possible culprit here is that the first canvas of your document is somewhat complex, and Quick Look is taking a while to generate a preview upon save.

To turn this off, uncheck the "Include Quick Look Preview" checkbox in the Document Inspector. (See attached screenshot.)

Does that help?
Attached Thumbnails
Click image for larger version

Name:	og5-quicklook.png
Views:	250
Size:	31.1 KB
ID:	1988