View Single Post
I too was having weird issues with assigning a clipping shortcut.

I recently upgraded to snow leopard (Mac OS X 10.6.2) and I noticed Clipping from other applications into OmniFocus stopped working. I went into the OmniFoucs preferences to try to record a Clippings Keyboard Shortcut but it didn't want to take/record it.

I looked in System Preferences -> Keyboard -> Keyboard Shortcuts -> Services and saw OmniFocus:Send to Inbox was checked but no keyboard shortcut was listed. I also saw OmniOutliner: Add to clippings was checked and it listed a keyboard shortcut and that worked fine for OmniOutliner. But I couldn't clip anything for OmniFocus.

It appears there's an issue with recording and storing the keyboard shortcut for clipping.

I screwed around with it for quite a while and finally managed to get a clipping shortcut recorded and everything went back to normal. Honestly I'm not really sure what steps it took to get the clipping shortcut recorded but here's my best guess at how to get it to record:

1) Go into System Preferences -> Keyboard -> goto Keyboard Shortcuts -> look at the Services and find OmniFocus:Send to Inbox. If there is no keyboard shortcut listed then you need to get one in there.

2) Now go into your OmniFoucs preferences -> clippings, and try to record a keyboard shortcut. OmniFocus will complain about System Preferences being open and ask you to quit. Go ahead and quit and hopefully your keyboard shortcut will actually be recorded this time.

The steps above worked for me. Hope this helps someone.


NOTE - maybe having System Preferences open had nothing to do with it ... it might have been me trying different keyboard combinations until one took ... I noticed that the keyboard shortcut won't record if OmniFocus doesn't like the combination you want ... so maybe it all comes down to the combination you are trying to put in ... the one that worked for me is Command Shift , (cmd-shift-comma).

Last edited by itmiller; 2010-02-17 at 08:36 AM..