View Single Post
You need to verify that you have the "Mail on Leopard (or later) box checked in the Clippings Preferences page, and that it appears in the list above "Any Application". "Copy Clippings to:" should have the "Quick Entry" radio button selected. The Clip-O-Tron icon at the bottom right should have a red arrow pointing up, not a green arrow pointing down.

If your settings are otherwise, you'll get some or all of the behavior you report.