View Single Post
No, not a bug. You're using a date format that results in a longer string than will fit in the default column size with the default font setup. With a 2 digit year you'd be fine, with a smaller font size you'd be fine, or with a wider column width, you'd be fine.

To adjust the column width, make sure you have the column labels showing (turn on the view bar with View->Show View Bar), then drag the separator between the column labels as necessary. Getting the settings to stick is a little bit fiddly; a perspective will save and restore the columns if you have the Restore Layout box checked in the perspective. To set the default settings, you need to close all but one window, set the columns as you want them, then close that last window. You would be forgiven for thinking that wasn't immediately obvious :-)

You do a similar drill for setting up the columns in the Quick Entry box—bring up the QE box, make your changes, close it without creating any new actions. To adjust the column widths, you need to be in OmniFocus as the frontmost application when you bring it up.