View Single Post
Here's the response I received via email from Jameson Brown, a support ninja:
Sorry for the trouble! Here are a few troubleshooting steps you should try for Bonjour sync:

- First, recycle the power on your wireless router, then try synching again. As basic as it sounds, this has been the #1 culprit with Bonjour synching issues.

- Reset synching on the desktop by going into the Sync pane of the Preferences menu, setting the sync method to "Nothing", then set it back to Bonjour.

- If you're running Tiger, try turning off the firewall, then sync OmniFocus. If that worked, I'll send you detailed instructions on how to sync with the firewall on; for now, we just want to get you up and running.

- If you're running Leopard, go into System Preferences>Security>Firewall, and make sure it's either set to allow all incoming connections, or add OmniFocus to the list of applications allowed access.

- On your desktop's network settings, make sure there aren't any proxy servers set up.

- Turn your iPhone off and back on.

- Offices typically have firewalls installed on their wireless networks that will block the iPhone's attempt to connect with your Mac for synching. You may need to contact your IT department so they can open up a port for you to sync with.

You also have the option of setting up an ad-hoc network, which is a network that's broadcast directly from the wireless card on your Mac, which your iPhone can connect to in order to sync :
I tried the things he suggested, along with some suggestions from the FAQ, and finally got things to sync properly.