View Single Post
You are correct, that it is the culprit - 106 zip files is a lot.

There are two ways to make sure that this doesn't occur:

1. Synch both your iPhone and Mac with each other twice each within an hour to make sure the database is compacted.

2. Make use of the Archiving feature in the Desktop version to reduce the size of your active database - however, be warned that this means that you will not be able to see older (you get to define just how old) completed actions on your iPhone so don't do this if that is of high importance to your workflow*.

To do so:

1. Select the Move Old Data to Archive... option from the File menu:

2. Choose the date that you wish to archive back from:

(N.B. As I recently did this I don't have any old data to archive)

3. If and when you need to see any of that data, select the Open archive option in the File menu (below the selected option in the screenshot in 1. above).

Note, it is quite seamless to view archived data and to perform this.

Personally, I do this at the start of each month and have a repeating task in OmniFocus to remind me to do it.

* added for the benefit of anyone else reading, btw, as this isn't important to you!