View Single Post
Since upgrading to OmniFocus 1.7.1, I've started receiving the following error dialog every time I attempt to sync:

Unable to synchronize database with server.

Cannot synchronize.

The remote database appears to have been reset and is no longer able to reach transaction identifiers ( jrUXMuzjXOt ).

I'm configured to use a remote WebDAV server (my Mac Mini running Apache with mod_webdav). This setup has worked fine for me for several months, interoperating with OmniFocus on my iPhone.

For kicks, I moved what I thought was the sync directory (under /Library/WebServer/WebDAV) out of the way (an OmniFocus.ofocus directory). Then I manually forced a sync, and it "worked" and created this directory, but shortly thereafter I get the "Replace your database and start syncing?" dialog again. I thought "Ok, why not, I'm synced", told it to go ahead, and it reverted my database to something from at least two days ago!

I haven't done anything with OmniFocus on my iPhone this entire time, just to keep it simple and help isolate the problem.

Is anyone else seeing major WebDAV sync issues after upgrading to 1.7.1? Any suggestions for someone who is seeing these issues? For now I'm refusing to sync at all, making it useless on my iPhone, and could really use some help escaping from this sync hell. Thanks!