View Single Post
Are you sure you don't have any Application Keyboard Shortcuts defined for Mail? If the triangle is closed, you wouldn't see it mention the OmniFocus service.

You could also try moving your Library/Preferences/ file aside after quitting your applications and then restarting first OmniFocus and then Mail.