View Single Post
OmniFocus has it's own notification system - everything happens right on your phone. (We don't use Apple's push notification system, in other words.)

If you open up OmniFocus' Settings screen - the gear button on the right side of the toolbar from the Home screen - you can scroll down to the "Sounds & Alerts" preferences. Tap that, then set everything on the next screen to "Off".

Hope that helps!