View Single Post
Mac OS 10.6 also took the step of disabling any keyboard shortcuts assigned to your services. You'll need to re-enable the service shortcut using System Preferences.
Note: Apple added several new default keyboard shortcuts for services offered by their applications in 10.6 - if your previous shortcut conflicts with one of Apple's, you will need to choose a different one.

It also appears that Apple will no longer allow you to use any of the Function keys as the shortcut for a service; you can't, for example assign F19 to one of the services that OmniFocus (or iChat, for that matter) offers. You can, however, use a function key along with the command key.

Personally, I use command-F6 for my clipping shortcut. (Folks on MacBooks or MacBook Pros may need to use the "Fn" key to access the function keys; a lot of Apple's keyboards - particularly on laptops - have their own built-in uses for those keys.)

If you were previously using one of the troublesome keys in your OmniFocus clipping shortcut, you'll need to find a new keyboard combo to use. Ken finds that Shift-Command-Comma works well as a clipping shortcut for him.
To re-enable your keyboard shortcut, do the following:
  1. Open System Preferences from the Apple menu.
  2. Select the "Keyboard" pane, and switch to the "Keyboard Shortcuts" tab.
  3. Select "Services" in the list on the left. (Next to the icon that looks like a gear.)
  4. With "Services" still selected, scroll the right hand pane until you see the "Text" grouping.
    (There's a bug in 10.6.x which can cause this pane to be blank; see the next post for what to do.)
  5. Continue scrolling in the Text group until you see the "OmniFocus: Send To Inbox" entry.
  6. If the box to the left of "OmniFocus: send to inbox" isn't checked, check it. You should see a keyboard shortcut specified in this line which matches the one you chose in OmniFocus' preferences. If you don't see a shortcut here, quit System Preferences and return to OmniFocus' preferences. Clear out the shortcut and reassign it, then check System Preferences again. If you still don't see a shortcut in System Preferences, please try double-clicking at the right end of OmniFocus' line in the list, then type the shortcut you'd like to use directly into the list.

    If that doesn't work either, please contact the support ninjas so we can help.

Important Note: Unlike the 10.4 and 10.5 releases of Mac OS X, 10.6 releases will only automatically associate a custom keyboard shortcut with a service if it includes the Command key. If a shortcut omits that key, customers need to open the Service menu and make OmniFocus' entry visible before the shortcut will work. (And if you restart the app in question, you'll have to repeat this process.)

In the early days of OS 10.6, we got a lot of email from folks that were unaware of this change in the OS and whose keyboard shortcuts weren't working the way they expected. Rather then let this continue indefinitely, we changed OmniFocus so it required that key as part of the clipping shortcut.

This has the drawback of requiring some customers to choose and learn new shortcuts, but once they do so, it should work consistently and predictably. We hope that's an improvement over the previous situation, where sometimes it would work and sometimes it wouldn't.

Last edited by Brian; 2011-03-10 at 11:30 AM.. Reason: add info on typing shortcut directly into System Prefs