View Single Post
I'm still not sure that I correctly understand where you did which steps, but I can describe a scenario that would produce the behavior you apparently experienced. If you changed the auto-complete setting on your Mac, then before syncing your Mac and your iPhone (remember, both devices need to do a sync, and in the right order, before the updated data will be propagated everywhere) you completed the last action in that SAL, you would get the auto-completion because in the iPhone's database, that SAL was still marked to auto-complete. Only after the Mac wrote out the updated data to the central repository, and the iPhone subsequently read it and updated its local repository, would the auto-completion be turned off.