View Single Post
Satri, you can do this for most any Mac OS X application.

Select OmniFocus in the Finder, then select "Get Info" from the file menu.

You'll see a "Languages" section in the window that appears. Uncheck the French localization (and any other localizations you want to not use) but leave English checked.

Quit and restart OmniFocus; it should now use the English localization.