The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
LOTs of crashes with WorkspaceExpireTime set to 5 min Thread Tools Search this Thread Display Modes
The WorkspaceExpireTime setting is great. Since I set it to 5 minutes I'm running my 40 open tabs distributed over several workspaces on less than 700 MB memory footprint on average.

Only thing that tends to make this setup completely unusable is that now the application crashes MUCH more frequently than ever before. Most of these crashes are "out of nothing" which together with the low WorkspaceExpireTime indicates that it happens when releasing the memory for inactive workspaces.

Just to give you an idea: since I started working today I had 5 crashes. There were days when I had even more, depending on how often I switch workspaces. I actually forgot sending crash reports far too many times, now I try to not miss a single one :) They all have the same comment: "crashed while doing nothing".

I'm aware that often such crashes are caused by plugins, however just out of curiosity - are these crash reports actually read at all, or are they just redirected to the null device? Since OmniWeb is no longer a pay ware product I guess there's not too high a priority on fixing these bugs, but, needless to say, such fixes would be greatly appreciated!

Comment anyone?
 
We do love to fix crashes when we can, but we have limited bandwidth available for OmniWeb right now. (We're still working on our "iPad or Bust!" initiative that I outlined in January, 2010—though we're finally getting very close to shipping the last of those five apps!)

Have you noticed any particular pattern to when the crashes happen? Is it when a workspace containing a particular website expires? If you can narrow it down to a workspace containing a single web page which reliably crashes when it expires, that would make this crash a lot easier to track down.

Thanks!
 
How often are you switching workspaces before you get a crash?

I set my WorkspaceExpireTime to 15.5 seconds via

Code:
defaults write com.omnigroup.OmniWeb5 WorkspaceExpireTime -float 15.5
and started switching between some of my smaller workspaces. I didn't have any trouble causing the footprint to climb, as seen here:



Crash immediately followed.

Perhaps the high-water mark keeps getting bumped higher and higher until the address space is exhausted, even if the amount of memory in use isn't as high (though in my snapshot, there's a pretty hefty memory footprint, too!)
 
I hope I can find some pattern. It's funny. I had 7 crashes yesterday, today none yet. Maybe my trying to find a pattern has changed my way of using the program in a way that prevents crashes :)
 
Quote:
Originally Posted by mbert View Post
I hope I can find some pattern. It's funny. I had 7 crashes yesterday, today none yet. Maybe my trying to find a pattern has changed my way of using the program in a way that prevents crashes :)
I have that trouble too: I never seem to be able to crash OmniWeb when I'm actually trying to, in the debugger; only when I'm busy doing something where I really don't want it to crash.

(I'm surely jinxing myself, but OmniWeb hasn't crashed on me in over three months.)
 
Quote:
Originally Posted by Ken Case View Post
I have that trouble too: I never seem to be able to crash OmniWeb when I'm actually trying to, in the debugger; only when I'm busy doing something where I really don't want it to crash.

(I'm surely jinxing myself, but OmniWeb hasn't crashed on me in over three months.)
Well, you're "lucky" in a way :)
I had another two more crashes before I went home. But speaking of debuggers, just wondering, as I do have crashes at least more than one a day, maybe there's a way I can pass on more relevant information to you somehow? If there was an OmniWeb version with debugging symbols available I could just run it in the debugger and pass on backtraces when it crashes?
 
The Omni Crash Catcher does exactly that, if you let it. Of course, whether the report ever gets read and acted upon is another matter...
 
Well, I looked at one of these mails, and they contain thread dumps. That is by far a different detail level from what you get when you're in a debugger and enter 'bt' after a crash.
 
I believe I have found at least one pattern. Yesterday and today I had crashes after I had posted links or videos on Facebook (FB will resolve the URL and create a thumbnail) and switched away from the workspace in which I had facebook. The crashes came approx. 5 minutes after that, just at the time when according to my settings the FB workspace should have been cleared.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Export lots of drawings to PDF RushManbert OmniGraffle General 4 2009-10-09 11:06 AM
Lots of Bugs michaelrcorley OmniFocus 1 for Mac 2 2007-11-26 05:59 PM


All times are GMT -8. The time now is 07:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.