The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
A bit sluggish? Thread Tools Search this Thread Display Modes
Flash does slow down OW but I don't know if you can pin that on OW. I'm more inclined to chalk it up to poor web design. Flash heavy sites are an abomination. Try visiting mtv.

OW renders html as fast as anyone.
 
Quote:
Originally Posted by ghostdog75
Flash does slow down OW but I don't know if you can pin that on OW.
You can if OW is the only one of the browsers that keels over and dies.
 
Exactly. The sites I'm referring to are TWiT.tv and YouTube, which I don't think are badly designed sites, and they work perfectly in other browsers, just OW brings up the CrashCatcher randomly while listening to/watching content. However, I updated to 5.5.4b1, and haven't had any crashes yet. I'm hoping that it fixes whatever was wrong. I haven't used it very long yet, however, so I've yet to find out for sure.
 
OW does not crash for me, but ever since 5.5.3, I am experiencing the same issue as a poster below. I have to force quit virtually every time I use the app. I keep wanting to use it, and I keep enjoying the experience of using it, but I keep wondering why I use it when steady old Safari or Firefox never, ever, ever locks up, and does so for free. The stability of Omni's productivity apps is appallingly missing in OW right now.

Solving the history pileup in the latest beta is a step forward, but the app has to handle flash and java or it is dust.
 
Quote:
Originally Posted by tlee61
OW does not crash for me, but ever since 5.5.3, I am experiencing the same issue as a poster below. I have to force quit virtually every time I use the app. I keep wanting to use it, and I keep enjoying the experience of using it, but I keep wondering why I use it when steady old Safari or Firefox never, ever, ever locks up, and does so for free. The stability of Omni's productivity apps is appallingly missing in OW right now.

Solving the history pileup in the latest beta is a step forward, but the app has to handle flash and java or it is dust.
There are many threads on this. The issue has been with OW since the very first 5.5 sneaky peek. You may not have noticed it because the sites you visit now may be different or have changed since you were using 5.5.2. They are working on a fix. Well, they have a fix (integrating a new webkit), but it requires a lot of changes to OW as a whole.
 
Quote:
Originally Posted by Forrest
There are many threads on this. The issue has been with OW since the very first 5.5 sneaky peek. You may not have noticed it because the sites you visit now may be different or have changed since you were using 5.5.2. They are working on a fix. Well, they have a fix (integrating a new webkit), but it requires a lot of changes to OW as a whole.
Yeah, I've been having the exact same problems. If it requires changes to OmniWeb, then make the damn changes! I am completely bawling that I wasted my hard-earned money on this browser which always crashes, and I want a fix out REALLY soon or I want my money back.
 
It was never our intention to keep you waiting so long on these fixes. We are working on it though and will get an update out to you as soon as it's ready.

WebKit is under heavy development and there are quite a few big changes to it that require us to a.) rework things in OmniWeb or b.) that have been in development for quite some time within WebKit that we're waiting for to reach a more stable state.

Things are getting closer though thanks to all those that contribute to the WebKit project.
 
Thanks for the update. I can't wait unitl 5.6 or even 6.0, whenever that is. I've messed with some of the webkit nightlies, and they really do seem to handle memory a lot better.
 
It has been one hell of a wait though... it must be about 8 to 10 months that this CPU hogging bug has been around (since the first sneaky peek, IIRC).
 
Ditto Here. And its *hard* to be sluggish on a C2D machine.

With a few tabs open *firefox* is running circles around OW, and that's without Bon Echo.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sluggish Performance with iOS 4.2 patgallant OmniFocus for iPad 6 2010-12-03 04:30 AM
OmniGraffle 4 super sluggish Daniels OmniGraffle General 1 2010-03-03 11:44 AM
Omnifocus getting progressively more sluggish andrewebling OmniFocus 1 for Mac 4 2009-12-01 02:55 PM
Sluggish performance: launch alastair OmniFocus for iPhone 7 2008-07-15 08:13 PM


All times are GMT -8. The time now is 11:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.