The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Another site that doesn't work with Omniweb Thread Tools Search this Thread Display Modes
http://www.hondafinancialservices.com/?untypeflag=U

So many financial sites now that I have almost had to abandon the use of the browser when paaying bills online. Sad
 
It works for me; you just have to click the link on the warning site to continue. It's true that you're better off not using OmniWeb for high security sites because it's more easily hacked than one of the "major" browsers. IMO it's best to keep one of these browsers available to use just for high security sites. Chromium is the browser I use for this purpose. Open the security browser just for these sites and close it as soon as your transaction is complete.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spoofing will not work for IE only site nancymurray OmniWeb Bug Reports 4 2009-11-01 07:58 PM
Site OW won't work with xiamenese OmniWeb Bug Reports 1 2007-06-28 09:54 PM
Does this site work with OW 5.1.3 Ochi OmniWeb General 2 2006-07-18 08:37 PM


All times are GMT -8. The time now is 04:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.