The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 4 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Automatic Labels & Formatting Thread Tools Search this Thread Display Modes
I am trying to recreate in OO4 a template I had in OO3 called "Harvard" -- a simple I.A.1.a.(1)(a) with indents. (copying the template file and pasting it into the OO4 Template location yields a defective template.) In OO4 I can get it to look right for the first level I and its children and I think I have defined the row styles correctly but the labels and formatting do not carry through to the second level I and its children. Once thus defined, shouldn't the styles for each level be consistent? What am I missing?

How does one know if a given selected row is subject to a style in the style drawer? Should all the level 2 rows, for example, light up when "Level 2 Rows" is selected in the Styles Drawer?
Attached Files
File Type: pdf Harvard Example.pdf (124.6 KB, 152 views)
 
I had to clear out all the styles in the Style Drawer. Then I went level by level and created/defined/formatted each level. It works. The attributes carried over to the next level 1 and its children.

Then I opened an outline created in OO3 and applied the "Theme" "Harvard" to it and the levels are not formatted as Harvard.

JEEZ! It shouldn't be this difficult. This version is obviously an improvement, but sometimes I think my simple needs were better handled in MORE II.

I would suggest that there be a similar template supplied with the program and perhaps a legal-labelled one, too (1, 1.1, 1.1.1, etc.)
Attached Files
File Type: pdf New Harvard.pdf (116.3 KB, 139 views)
 
I don't know why you were unable to copy the template from OO3, they are still compatible. How was it defective? I'm also unsure why you had to clear any styles out first, but there is a quick way to do that by selecting all of them in the sidebar by selecting the first one and then shift-clicking on the last one, and then open the gear menu at the bottom of the sidebar and select Clear Style. If you have a Pro license, there is a script that was created for OO3 that sets the Harvard labeling that still works.
 
Hi Derek,

In OO3, I had been using a bunch of scripts from the Useful Scripts download, but several stopped working when I upgraded to OO4. So when I saw this posting of yours, I downloaded the folder anew, and lo and behold, several of the scripts that hadn't worked before - such as Collapse to Level X - started to work again.

But another script - Merge Selected Rows - does not work. Eevry time I try to run it, I get this error message:

The script "Merge Selected Rows.scpt" could not complete.

AppleScript reported the following error:

The operation couldn't be completed. /Users/Me/Library/Application Scripts/com.omnigroup.OmniOutliner4/Merge Selected Rows.scpt: execution error: OmniOutliner 4 got an error: Cannot make or move that element into that container. (-10024).
 
None of the scripts were updated in that package so that's odd. I'll have to take a look at script.
 
Have there been any thoughts of updating these for OO4? Or, if they work, making them easier to find on the website. I always found the scripts very useful. In particular, Harvard-ize and Collapse to level X.

Thanks,
Steve

The harvard-ize script doesn't work for me. I find this very helpful for my work. I'm getting an error message that looks like:

-10006
Can't set value of attribute "heading-type. . . etc)
 
Quote:
Originally Posted by steve View Post
The harvard-ize script doesn't work for me. I find this very helpful for my work. I'm getting an error message that looks like:

-10006
Can't set value of attribute "heading-type. . . etc)
Do you have a Pro license?
 
Yes. 4.0 (v162.8)

Thanks,
Steve
 
Hmm, I was getting that error and then it started working again. I'm at a complete loss as to why right now. If on the off chance you haven't relaunch OmniOutliner since adding your pro license, you do need to do that depending if you on what mode you used the trial in.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 07:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.