The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 4 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Move bug in 4.0.1 Thread Tools Search this Thread Display Modes
I'm seeing a yucky bug in the 4.0.1 release. Anyone else?

1. Put cursor into a row that has rows at the same level above/below/both.

2. Press Command-Control-up arrow or Command-Control-down arrow to rearrange the row.

Expected behavior: Row should move.

Observed behavior: Row does not move.

3. Close document.

4. Open document. The order is correct.

Additional info:

Tested under OS X 10.9.1 (13B42) on a 2010 MacBook Pro 15-inch.

Tested using an existing document as well as a new document.

Choosing Organize > Move > Move Up or Move Down displays the same behavior, so it's not limited to the keyboard shortcut.

The template/style doesn't seem to matter. Seeing it in the 4-5 documents I tested.
 
This is likely a result of fixing bugs with sorting happening too early. If you end editing it will allow you to move it correctly instead of having to re-open the file. We'll get this fixed for the next release.
 
If I understand you correctly, that means clicking the bullet to select the whole row and then moving the row. That throws a wrench into the advantage of being able to move things quickly without moving fingers from the keyboard.

(Or are you just acknowledging the bug and offering a workaround?)
 
Yes, this is a bug. You do not have to use the mouse though, you can toggle editing with cmd-return, or the esc key if you have your prefs set to allow that.
 
This bug affects my workflow quite severely - any news on when a bug fix can be expected?
 
+1 for the effect this bug has on my workflow and eager anticipation to see it fixed.

And no, the workaround to use cmd-return to exit the edit mode has no affect on whether I can move the row either with the keyboard or the menu selection.

Last edited by Mondozer; 2014-04-14 at 03:21 PM..
 
This was fixed in 4.0.2, released on Feb 6th. If you are still seeing this behavior please contact support.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 04:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.