The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Backspace sending back when deleting text in a text box Thread Tools Search this Thread Display Modes
I don't believe this is actually an OmniWeb bug (as I've also experienced it in Safari). It may be related to SteerMouse or the PS/2 adaptor I'm using, not sure at this point.

I'm looking for a way to disable the backspace shortcut for the back button. Due to some sort of interference from something, holding down the backspace key to delete text in a text box will occasionally cause the browser to go back (several pages, sometimes). This is incredibly irritating, but as I don't think it's actually an OmniWeb issue, it may end up being easier to solve by disabling that useless shortcut entirely.

So, is there any way to disable the backspace-sends-back shortcut completely?
 
Only when the text box is not in focus, IME.
 
Quote:
Originally Posted by Forrest View Post
Only when the text box is not in focus, IME.
Yes, in your experience. ;)

But as I very clearly stated, the text box is most certainly in focus, as I'm actively deleting text from it. :)
 
This has never happened to me, yet, so I guess it must have something to do with the additional stuff you are using. What is SteerMouse? Could it lead to the text box losing focus under certain circumstances, maybe only for the fraction of a second? That's what I guess is happening. I don't think a PS/2 adaptor could be the culprit unless it sends strange keyboard codes from time to time (like tab ;-) )—I think you'd have noticed that in other apps, too.
 
Quote:
Originally Posted by zottel View Post
This has never happened to me, yet, so I guess it must have something to do with the additional stuff you are using. What is SteerMouse? Could it lead to the text box losing focus under certain circumstances, maybe only for the fraction of a second? That's what I guess is happening.
SteerMouse is like USB Overdrive, except with MX Revolution support.

Quote:
Originally Posted by zottel View Post
I don't think a PS/2 adaptor could be the culprit unless it sends strange keyboard codes from time to time (like tab ;-) )I think you'd have noticed that in other apps, too.
Yes, it does occasionally send strange key codes. I've yet to actually find a decent USB-to-PS/2 adaptor (and I've been through many, I should probably just upgrade to one of Unicomp's USB boards at this point). They either has messed up repeat patterns, low sensitivity (lose characters if you type too fast), or send weird codes when they reset themselves from time to time like much current one.

So, yes, a strange key code from the PS/2 adaptor or from SteerMouse could be the culprit, but I'm not incredibly interested in determining that, as neither of them are going anywhere anytime soon.

What I'm really interested in, is finding a way to disable this shortcut of dubious usefulness. ;)
 
Quote:
Originally Posted by GeneralAntilles View Post
What I'm really interested in, is finding a way to disable this shortcut of dubious usefulness. ;)
Unfortunately, it is a shortcut of universal occurrence as other browsers implement it for going back in the history too...
 
Quote:
Originally Posted by GeneralAntilles View Post
But as I very clearly stated, the text box is most certainly in focus, as I'm actively deleting text from it. :)
Actually, what you said was:
Quote:
holding down the backspace key to delete text in a text box will occasionally cause the browser to go back (several pages, sometimes).
Not a single mention of the text box being in focus.

Anyway, do you have an example link for us to try and duplicate the issue?
 
Quote:
Originally Posted by Forrest View Post
Not a single mention of the text box being in focus.
If the text box weren't in focus, I wouldn't be trying to delete text from it, backspace sending "Back" would be the expected behavior and I wouldn't be asking for help here. :)

Quote:
Originally Posted by Forrest View Post
Anyway, do you have an example link for us to try and duplicate the issue?
Like I said, I don't believe this to be an OmniWeb bug and I'm not filing a bug report, so a reproducible testcase isn't important. If you really want it (I can pretty much guarantee you wont be able to reproduce it, as I'm sure it's one of the things about my setup I mentioned in the first post), though, find yourself a textbox on any website (multiline or not), enter some text into it, and you may or may not have the browser treat backspace as "Back" while you're deleting text.

Again, I'm not looking to submit a bug report, I'm not looking to get this "bug" "fixed" in OmniWeb, I'm just looking for a workaround to disable the backspace "Back" shortcut. :)
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending text from Emacs to OmniFocus Ken Case OmniFocus Extras 1 2009-05-07 08:33 AM
zoomed text editor icon coming back in 5.6? danielandrews OmniWeb General 30 2008-11-16 08:15 PM
text won't create new text line alassiter OmniGraffle General 1 2007-12-18 01:12 PM
Form text field doesn't always accept a text drop Ward OmniWeb Bug Reports 2 2006-06-18 10:12 AM


All times are GMT -8. The time now is 07:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.