The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Extras
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Verify Next Actions Exist Thread Tools Search this Thread Display Modes
Quote:
Originally Posted by SpiralOcean
It's your world boss... :-)

The frustrating thing about using the applescript to reference the growl dictionary is... it forces a person to install growl to use your applescript. At least, I haven't found a way to load the applescript without running the applescript without having Growl installed so I can delete the code.

For those not versed in Applescript, or using scripts, they may give up when they get the dialog box asking for the Growl dictionary.

Like I said... it's your code... your world.
I think there is a way to write the script so it doesn't use Growl if it isn't installed. You would still need to install Growl to edit the script. But for people wanting to muck about with the guts of the script, I don't think that's an unreasonable burden.

(Actually, if you don't have Growl installed, you can just pick any old app when prompted by Script Editor. You'll still have to delete the Growl references in order to save changes, but you don't really have to install Growl to edit the script.)
__________________
Cheers,

Curt
 
I'm using rev. 94791 and it seems to have stopped working. I get the following error message:

Quote:
AppleScript reported the following error:
OmniFocus got an error: Some parameter is missing for activate.
I think this is an essential script. I hope Omni bakes in this functionality.
Is this script working for others?

update:
The script works, but I get the error message. Perhaps a minor part of the script isn't working for me-- i.e. growl integration.

Last edited by steve; 2007-11-18 at 02:44 PM..
 
Quote:
Originally Posted by steve View Post
The script works, but I get the error message. Perhaps a minor part of the script isn't working for me-- i.e. growl integration.
Steve,

Are you using version 0.4 of my script?

This error message is part of a very strange OF bug that we (Tim, Ken, and I) have been unable to track down. Ken and I both saw the bug, then it disappeared and we can't recreate it. There's another thread on the extras forum about it.

You could try deleting the "activate" line in the script, just below the [I]tell application "OmniFocus"]/I] line. That shouldn't cause any problems.
__________________
Cheers,

Curt
 
Yes, Curt. I am using .4. It seems to work, so I'm cool. Unfortunately, the clear next actions doesn't work at all. Do you still use this script in your reviews? I think it is a pretty key concept.
 
Steve,

The Clear Script only clears from selected items in the content pane. Is that how you are using it?

I use the Verify script on a daily basis. I haven't add a Missing NA since posting the Clear script, so haven't tested it since then.
__________________
Cheers,

Curt
 
Hey Curt,

I get this message when I invoke the clear script:

Quote:
AppleScript reported the following error:
OmniFocus got an error: Can’t set name of tree to "Fundraiser Policy".
I'm amazed that you don't have many Missing NAs. I just counted and I had 32. I probably need to do a better job with daily and weekly reviews.

Steve
 
Quote:
Originally Posted by steve View Post
I get this message when I invoke the clear script...
Steve, is that a project or an action group? Did you select it in the sidebar or in the main content pane? (If I can duplicate the problem, I'll probably be able to fix it.)


Quote:
Originally Posted by steve View Post
I'm amazed that you don't have many Missing NAs. I just counted and I had 32. I probably need to do a better job with daily and weekly reviews.
I have a Show Missing NAs perspective that I use if any Missing NAs show up in my daily review (Planning mode, no focus, active projects, grouped by folder, show remaining actions, "Missing NA" entered in outline search field).

Often my items with Missing NAs are complete, so I just check them off. Otherwise I give them a next action. This is crucial to closing my open loops. If I am not prepared to give them a next action, then the project should probably be put on hold. A default next action might be "Brainstorm for 10 minutes about potential next actions to move project X towards successful completion."
__________________
Cheers,

Curt
 
Quote:
is that a project or an action group? Did you select it in the sidebar or in the main content pane? (If I can duplicate the problem, I'll probably be able to fix it.)
Project selected in main content area. I've tried all the variations, (1 selected, all selected, none selected) but nothing seems to work. Don't spend too much time on this— I need to do my reviews and simply have less open loops. Gosh I hope this gets built in.

Thanks, Curt!
 
I can't duplicate that problem, but did uncover one that seems to have crept in with recent changes to OF. Try this version to see if it is any better: Clear “Missing NA” Prefixes.zip
__________________
Cheers,

Curt
 
Hey Curt,

Thanks for trying. I still get this message:
Quote:
The script 'Clear “Missing NA” Prefixes' could not complete.
I'm OK. . . I'll clear them by hand and learn to avoid projects w/o next actions!
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Feature Suggestion: Verify Date Input chmars OmniFocus 1 for Mac 1 2012-08-17 04:14 PM
Send OF item to EverNote (AppleScript exist?) ende OmniFocus 1 for Mac 0 2011-11-08 10:10 AM
easiest way to determine whether enough resources exist for a project Aires OmniPlan General 2 2010-03-22 01:06 PM
Problem with repeat when start date and due date exist SpiralOcean OmniFocus 1 for Mac 2 2008-09-05 04:43 AM
Thanks to exist jiliwi Omni Lounge 1 2006-06-25 10:28 PM


All times are GMT -8. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.