The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Omnigraffle 5.4 - Apple Script Font Issue Thread Tools Search this Thread Display Modes
I just updated to omnigraffle 5.4 and my usual script for creating a table of contents is no longer working. I believe the error is in the setting of the font attribute. The text boxes are being created in omnigraffle however they have no font attributes set for them. I just select them and set a font and size and everything shows up just fine. Was there any modification made to this function?

Same Issue here...I'm trying your solution to see if it works...(processing)...yep, that works, thank goodness. I would also like to know a fix for this.
One long-standing piece of flakiness in OmniGraffle's scripting of text properties is that the scripted change is sometimes only shown at other zoom levels - change the zoom and it become visible, return to the original zoom level and it vanishes.

(A backfiring of some attempt to economize on screen refresh events ?)

Hard to know whether this is a factor without seeing your script. But it might be worth adding a zoom level nudge at the end of it. (Subject to the caveat that things will initially still be amiss at the original zoom level).

Something like:

tell application id "OGfl"
	tell front window to set zoom to (zoom * (0.999))
end tell
The most important thing, however, is to report this through OG Help > Send Feedback ...

(things can easily get missed on this forum)
Just dropping a quick note here to let you know that this issue should be fixed in the latest 5.4.1 beta, which can be found on our sneaky peek page.

We're hoping to have 5.4.1 wrapped up early next week and submitted to the Mac App Store as well as putting out a release candidate for it.
"Vroom! Vroom!!"
Originally Posted by Joel View Post
Just dropping a quick note here to let you know that this issue should be fixed in the latest 5.4.1 beta, which can be found on our
I was having the same problem and downloaded the 5.4.1 beta. Happy to report that it worked!

This not only fixed the TOC issue but also corrected a printing problem I was having where I could not print beyond page 2 of a document. I was getting the error message (on the 2nd page printout) of:

ERROR: undefinedresult

[ ]


Now it seems to be fixed, thanks.
I installed it, but something weird is going on: I run the TOC script and see the lines created, but I can't view the numbers or canvas names until I quit the document and then relaunch it. Any thoughts on that?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Issue: Embedding Multiple Copies of the same font in a PDF thenate OmniGraffle General 0 2012-06-15 12:43 PM
Chartwell Font - Ligatures or Opent Type issue? JonathanLamb OmniGraffle General 6 2011-03-29 04:35 PM
Omnigraffe or OS X Font Issue 64-bit? James Sievers OmniGraffle General 0 2010-11-22 09:26 AM
Apple Script for layer visibility in OmniGraffle Pro 4? nicoledb OmniGraffle General 0 2009-02-04 07:52 AM
Apple-Script triggered exports of selection into separate images in OmniGraffle 5 Pro Scifer_2008 OmniGraffle General 0 2008-09-03 06:01 AM

All times are GMT -8. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.