The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing
FAQ Members List Calendar Search Today's Posts Mark Forums Read

SOLVED: No root transactions found ... Thread Tools Search this Thread Display Modes
I have
- an iMac at home
- iPhone
- a MBP at work

I got OF syncing well with the iMac at home.

Went to work and tried to sync with MBP and started getting this error on both the MBP and the iPhone.

Unable to synchronize database with server.
Unable to read document.
No root transactions found in "".

No idea at all what this means or what do do about it.

Any suggestions would be helpful. Thank you.
I see that a lot of the other topics are getting replies, but not this one yet. Is anyone else having this error?
I renamed my old "OmniFocus.ofocus" database on MobileMe to "OLD - OmniFocus.ofocus".

I also made sure that the path in MacOF Sync Settings was the following:


Make sure to check capitalization.

I then synced form the iPhone first since this is where my most current database was. I chose to use "local database". Then I synced with MacOF and used "server database".

*** The main thing that it would be helpful to have on the sticky on the top of this forum is the default path! I had deleted mine and could not find what the default was.
I was having the same problem, but renamed "OmniFocus.ofocus" with "OLD_OmniFocus.ofocus", and a new database file was created from my desktop (which was up-to-date) application at Sync.
This also solved my problem. While I understand the programme is only Alpha, why are we having to fathom all of this out?
To some degree, mysterious errors are part of the territory when an application is in beta. We've had extra challenges with this particular adventure because Apple is transitioning .Mac to MobileMe and several other WebDAV services do not behave quite the same way as MobileMe. We want to fathom these things out on your behalf, but the more information you can give us, the easier that will be.
So much for alpha or beta. Just had the same error and lots of other syncing fun. The old solution still works, though. Lost some actions that I entered on the iphone, but it seems that otherwise everything is fine now.
I am having this exact problem but the "old solution" IS NOT working for me. I have successfully rebuilt the OF database in my iDisk documents folder as advised by support ninja and the iMac version is working fine. But my iPhone copy absolutely refuses to play ball. If it wasn't for my old faithful subscription my OF database would now be completely pointless. How do I resurrect my iPhone syncing?
If you've got the desktop machine syncing to MobileMe successfully, just upgrade your iPhone OmniFocus to the 1.5.3 version that just came out, then click the Reset Database button on the Settings page and set it up to sync again.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
sync error- no root transactions found in... oneapple OmniFocus Syncing 1 2010-03-07 11:17 AM
MobileMe "Root Transactions" problems [SOLVED: caused by iDisk syncing, see sticky.] codog24 iDisk/MobileMe/.Mac Syncing 27 2009-09-01 05:21 PM
"No root transactions found" error: Once more with feeling kklein OmniFocus 1 for Mac 10 2009-04-22 12:03 PM
No root transactions found epicurean OmniFocus Syncing 2 2009-01-14 03:45 PM
Unable to read document -- No root transactions found ewits OmniFocus 1 for Mac 1 2008-02-14 04:56 PM

All times are GMT -8. The time now is 08:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.