The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

WebDav with OSX Server Thread Tools Search this Thread Display Modes

I'm having trouble getting Onmifocus to sync with webdav. I've set up a webdav server using OSX Server and can create files in the webdav directory when I mount it through the finder on my desktop Mac. I can also browse it using Safari on my iPhone so I'm fairly confident that I've got the basic webdav service running correctly. I can sync my Ominfocus with my iphone using bonjour.

When I try to sync using webdav from either device I get the same error:

"Unable to synchronize database with server.

Could not access the WebDAV location < details../OmniFocus.ofocus-copy-in-progress-aefp6bPIslx/>.

Please make sure that the location set in your Sync preferences actually exists."

The console log on the client has this in it:

06/12/2008 23:03:13 OmniFocus[827] sync terminated with error: {
code = 409;
domain = "com.omnigroup.OmniFocus.XMLData.DAVHTTP.ErrorDoma in";
userInfo = {
NSLocalizedDescription = "Could not access the WebDAV location <https:// <<URL>> /OmniFocus.ofocus-copy-in-progress-aefp6bPIslx/>.";
NSLocalizedRecoverySuggestion = "Please make sure that the location set in your Sync preferences actually exists.";
NSUnderlyingError = {
code = 409;
domain = "com.omnigroup.OmniFocus.XMLData.DAVHTTP.ErrorDoma in";
userInfo = {
NSLocalizedDescription = "Unable to perform WebDAV operation.";
NSLocalizedRecoverySuggestion = "The <<DNS Name>> server returned \U201cconflict\U201d (409) in response to a request to \U201cMKCOL /Omnifocus/Tom/OmniFocus.ofocus-copy-in-progress-aefp6bPIslx\U201d.";
errorData = <....lots of hex...>;
errorDataContentType = "text/html; charset=iso-8859-1";
errorString = "<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n<HTML><HEAD>\n<TITLE>409 Conflict</TITLE>\n</HEAD><BODY>\n<H1>Conflict</H1>\nMissing one or more intermediate collections. Cannot create resource /<<path>>/OmniFocus.ofocus-copy-in-progress-aefp6bPIslx. [409, #0]<P>\n<HR>\n<ADDRESS>Apache/1.3.41 Server at <<DNS Name>> Port 443</ADDRESS>\n</BODY></HTML>\n";

The apache eror log on the server has this to offer:

[Sat Dec 6 23:20:00 2008] [error] [client] (2)No such file or directory: Missing one or more intermediate collections. Cannot create resource <<path>>/OmniFocus.ofocus-copy-in-progress-ir5D6YOs7ih. [409, #0]

Help: what have I missed? I'm running out of ideas!

It looks like OmniFocus just asked to make a new folder on the server, but the server came back with HTTP error 409 - "conflict". Maybe the account that's logged in isn't allowed to make new folders in that location?

Info on the 409 error posted here:

Thanks. I think I've just got this to work. The user account didn't have any rights at the root of the webdav mount (ie hostname/). I've granted the group in question read perms at the root and it now works perfectly. Looks like both the desktop and iphone webdav implementations need to be able to browse the filesystem.

Thanks for your help.


Would you please give us the steps you perfomed to set up WebDAV for OmniFocus on Mac OS X Server? There are instructions available for Leopard client, but not server.


It wasn't too hard at all. Assuming you've got the web services running on your server (I'd suggest HTTPS - even if only with a self signed cert for privacy) then you simply need to check the enable webdav option on the site's option pane in server admin. The only bit that tripped me up for a while was permissions related - the user account (as set up in the realms pane in server admin) need at least the Browse only right at the root of the webdav site - you can then give them webdav read/write at a sub directory level and all should work fine. My iphone and desktop clients stay in sync perfectly now.

If you need any more help I can post some screen grabs etc later - just let me know.



Thanks for the reply, I think I just need to RTFM a bit. It's easy to get WebDAV up and running, but if I mount, I get the folder /Library/Webserver/Documents/

I'm trying to figure out how to map either:

1. https://webdavstorage.
3. (dedicated local IP)

to a particular folder on the server, i.e. ~/WebDavStorage/.

I have an xserve in a data center that has real domain names, but I prefer to set it up on my local test server.

When I get it up and running I'll write up some instructions. Any hints would be appreciated, particularly for #2 above.
Nevermind. I had Subversion set up on the same port (443), which was interfering with WebDAV. Works now.
I'm not sure I can help there - I've simply set up an https web site for all my data transfer activity with it's own hostname and dns entry (both inside and outside the firewall - these resolve to different IP addresses depending if my laptop/iphone is on my home net or out in the big bad world). I've then mapped it's root to a directory on my sites volume and use webdav to a subdirectory (which is imaginatively called Omnifocus) but this is just a home rig. It gives me some respite care from wrestling with SAP on 64bit Windows by day :-).

Let me know if you get the root directory perms issue sorted out - it doesn't feel right at the moment!

Good luck,


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
WebDAV Lion Server joelande OmniPlan General 0 2011-11-02 12:01 PM
Personal WebDAV Server Murman OmniGraffle for iPad 4 2011-02-06 02:48 PM
WebDav problem with OSX Server 10.5 Tom Henderson Other WebDAV 0 2008-12-06 02:55 PM
Mac OSX Server WebDav and OF (iphone and DT) JohnJ80 Other WebDAV 3 2008-07-30 06:39 AM
WebDAV server dmcg Other WebDAV 0 2008-07-10 11:33 AM

All times are GMT -8. The time now is 06:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.