The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Templates storage Thread Tools Search this Thread Display Modes
This must be a dumb question but where does OmniOutline store the templates that I create? I created a template on my desktop and want it to be available from the 'New From Template' dropdown menu but I can't find out where they are kept so I can't drag my beautiful new template into it! Thanks
Hi Ron-

The templates should go in <home>/Library/Application Support/OmniOutliner 3/Templates

Derek M.
Support Ninja
The Omni Group
Thank you, I have done that but the drop down menu still doesn't seem to see it. Let me tell you more...:confused:
I have just switched to a new macmini from my old macmini. While using my old macmini I kept lots of files on a LaCie hard-disk. I have 'done' the simple switch macs and now seem to have 'omnioutliner 3' template folders on all three drives!!!
So I have
  1. My new macmini
  2. The old macmini working has a hard-drive with a firewire connection.
  3. The LaCie hard-drive. the question is 'where is my omnioutliner looking to find the template folder?!?' Is there any way of finding out?

This is what happens when you think you know what you are doing in upgrading your machine!:rolleyes:
It should be looking in your home folder. Most likely that resides on your new macmini. One thing you can do is go OmniOutliner -> Preferences -> Edit New Document Template, make some changes, then save it. This will then create a 'Default.oo3template' file in the directory where you want to place your template.

Derek M.
Support Ninja
The Omni Group
OK I did this and it edited my default template beautifully and placed it in the expected templates folder. It now fires up if I just click new. However, according to Finder there are 4 extra 'templates' that I have created in that folder. In the drop down menu there are two heading 'ronbailey' (me) and 'omnioutliner'. I was expecting to find my new templated under one or other of these headings in that drop down menu but they are not there.

That menu still has the edited version of the original default template and omnioutliners other templates eg Budget, Class Notes under a second heading of omnioutliner but without trace of my new templates. Should I expect to see these new templates when I use the drop down menu 'new from templates'?
Yes, you should see your template listed there. So you have it in the same directory that the default template file showed up in?

Does your template have the .oo3template extension on it?

Derek M.
Support Ninja
The Omni Group
Simplest solution would be to double-click the ones that are not showing up and then save them as Templates to make sure they are created in the right format in the right place.
I'm really grateful for all your patient help on this.
Yes, I have double clicked my new .oo3templates from the Finder window and they all burst into life.
I then saved them again as oo3template files and was told each time that a file of that name already existed in that file and did I want to replace it. I confirmed and it saved the templates there with their new dates, today, but when I click 'new from template they are still not there in the dropdown menu?!?

I can manage what I want to do from the Finder but I am now very curious as to why it behaves like this.

Thanks again.:confused:
As far as I am able to tell, OmniOutliner draws templates from
1. <your computer>/Library/App Support/OO3/Templates
2. <your home folder>/Library/App Support/OO3/Templates
3. built-in templates within the application itself

I'm having a little trouble following your description, so I'm unsure if this is going to be of any assistance.

I was having similar issues when working with templates. And it seemed like the more I fixed it, the more screwed up it became. And I couldn't figure out why. What I finally did was move all the templates from everywhere on my hard drive into one folder. I then moved all those templates (removing duplicates, etc) into #1 (because my computer is set up for multiple users and I wanted all users to have access to all templates).
Yes, it is up and working now but to honest I am not sure where it is accessing stuff from. I upgraded to ooP and that now picks up the other templates.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Scripts for calendar and storage mdmdiv OmniFocus Extras 0 2013-03-24 09:48 AM
DOM storage bmastenbrook OmniWeb General 0 2010-12-16 04:52 PM
Feature Request: Storage of Preferences phillychuck OmniFocus 1 for Mac 0 2007-07-25 04:13 PM
OmniFocus Data Storage ueila OmniFocus 1 for Mac 17 2007-07-04 04:35 AM
Information Storage samaparicio OmniFocus 1 for Mac 4 2006-11-29 10:52 AM

All times are GMT -8. The time now is 09:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.