The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

CalDAV setup - method not allowed Thread Tools Search this Thread Display Modes
Hello all,

I looked through the forums / searched a bit and couldn't find something on this, so asking in this thread.

I'm trying to set up a CalDAV account in OmniPlan 2.2 to an OS X 10.6 server. I have WebDAV set up and working to the same server (that took a bit of doing) with the same user credentials, but I keep getting "method not allowed" when trying to set up CalDAV.

I've tried set the Server Address in OmniPlan's account setup as:
the TLD
... same result. I can hit those last few URLs in a browser and see the collections / properties, and have the calendar set up as CalDAV in iCal on my Macs as well as calendars on my iOS devices just fine.

Any advice? Thanks,

similar problem to me. I try to reach our calDAV and server (ISERV) without any success with omniplan.
The problem is that I can use the caldav server without any problems via ical on mac an iOS and also lightning/thunderbird can reach the server with no problems and syncs, even tasks as to-dos.
But when it comes to omniplan there is a problem in the url I guess.
I can set up the account info with my username, password and
server-url: This entry gives me the green feedback that the account is everything alright, i guess.
But when I want to do a sync with that account omniplan reports an "unknown caldav error". When I try to create a calendar in omniplan it says: "URL not supported" (in german: URL wird nicht unterstützt) With my account I am not able to select a calendar to write to.
The same info when I try to sync to todo caldav. With my googleaccount I can sync to calendar entries. but I havent the ability to use the to dos which is my primary goal.
The question is: wht kind of calDAV url expects Omniplan too sync to caldav todos? Or with which caldav server can I sync to handle the url format out?
Thanks for help,
I'm not sure I can spot the issue you are both having directly, but maybe I can inundate you with a wall of helpful information.

The CalDAV account configuration itself is about getting OmniPlan to connect to the server, but _not_ to point to specific calendars. You specify a user and password, but this user does not necessarily correspond to any resource in your project. Typically you should omit the path to any calendars as well as the scheme from the server url (i.e. nothing in the "Server address:" field but ""). If you specify a scheme (http: or webcal:) you will probably get "unsupported URL". Of course you'll need to be sure that use are using the correct port and "SSL" setting.

When you use the account in publishing, resources in your project plan will be mapped to what CalDAV calls "principals" by email address. Matching email address must therefore be set up in both places.

Hope that's enough to get you moving along.

Thanks Tom (and I am following up on this with support as well),

Shortest question would be what would the username/pass likely be if not a specific user? I get that it's not the users on a project, and this is at the application level anyway... just that specific users have access to their calendars and the server in general, but there isn't a concept of a root/master user in CalDAV as far as I'm aware (that'd have write access to everything / acl access).

So yeah, if not the username/pass for a user on the server, just hitting the server and not specific user path which is what I've tried that gets "unauthorized", what would it be? Probably a better question is what is OmniPlan trying to read when testing a connection to the CalDAV server if it's not a specific user's calendar?

No, you do specify a username and password, as Tom said. It just doesn't necessarily have to be that of a resource in the document.
Yes, I get that a username and pass is needed... I think we're getting off track assuming I have any projects open or resources assigned with email addresses that need to correspond to anything. To clarify, this is at the app settings level. No resources on projects come into play at all. Fuggedabout 'em.

As in:
No documents (project plans) open, no resources with email addresses considered. In fact, for the purposes of this, we can assume this is a fresh install.

OmniPlan -> Preferences... -> Accounts
Account Type: CalDAV
User: [some regular user that has an account & a calendar on following server]
Password: [password for the user's account]
Server address:
Port: 443 / SSL checked (cert is valid)

Click Test -> Checking account... -> unauthorized

If the user and pass just need to be for a user with an account on the server and CalDAV services are running on that server, address is right / port is OK, that should work... no?
I am also getting this error.

When I enter our CalDAV (DAViCal) server in OmniPlan -> Preferences -> Accounts and I press "Test" A green "Account verified." message appears. All seems well.

Then, for a specific project, i.e., a specific .oplx file, I go to Project -> Configure Publishing & Subscriptions... and then I click the "+" and, in the pop-up selection box, under Subscribe, I click "free/busy times from Calendar Server". Then, in the "Server Account" drop-down box I click the CalDAV server I mentioned in the previous paragraph. Then a list of project resources pops up, with their emails. One of these resources has a calendar on the CalDAV server with a matching email address, and this resources is automatically highlighted. Beautiful. I click "OK". I click Project -> Publish and all seems okay -- it appears to publish everything to the OmniSync Server, which I also have set up and is working just fine.

Then I lay down a "Project -> Update" and a little sheet slides down with a progress bar that first says "Sync with OmniPlan server repository" as usual, then it says "Get free/busy times from Calendar Server". And then the sheet slides up and another slides down saying "An error occurred while updating. unknown CalDav error" And that is that.

Aside from that -- which a very bad error because we currently have to set the schedule for every resource for every project manually and it's a terrible thing -- I have another question: How does one *actually set* the free/busy times on the server? Resources often have multiple calendars set up on the server, so which one is actually read?

We have resolved this issue. It turned out to be a php problem in our Calendar server. We use DaviCAL. When Omniplan queries the sever for the free/busy times, the server uses a php method which is available only in PHP 5.2 or later. Our installation used PHP 5.1. When we updated to php 5.3, the error messages in the PHP logs went away, and now I can indeed suck in the free/busy times from Omniplan.

I don't know if this is the problem for everyone else, but it did seem to solve the problem for us.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recent Sync Error - Method not allowed (405) elanigan Other WebDAV 6 2013-03-09 10:50 AM
Could we have PNG allowed for Avatars? michaelaye Forums Feedback 1 2011-04-28 12:26 PM
WebDAV "method not allowed" (405) [server-side problem] joeminkie OmniFocus for iPhone 1 2010-08-17 11:03 AM
No comments allowed in OmniMouth? timwayne Forums Feedback 0 2008-01-18 07:47 AM

All times are GMT -8. The time now is 10:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.