The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus Syncing > Other WebDAV
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
local webdav syncing problem Thread Tools Search this Thread Display Modes
So I set up a local webdav server on OS X 10.4 using Manas' directions on his blog. It seems to be working. I can mount it locally with the finder and move a file into it or out of it. I can also mount it from a different computer, both on the LAN and over the internet in an SSH tunnel.

But when I tried to do an OF sync with it, it said that the sync had failed. And when I look in the WebDav volume, I see a folder with the following name:

OmniFocus.ofocus-copy-in-progress-kQxc0HuXvA8

Also, when I enter the webdav url into my browser, I get the following error:

"You don't have permission to access /omnisync/ on this server."

Any thoughts on this? I seem to remember somebody saying something about some extra sync logging you can turn on. But now I can't find that.

Could there still be some sort of a permissions problem I'm missing in the server config?

JL
 
paste the following into Terminal:

Code:
defaults write com.omnigroup.OmniFocus XMLFileManagerDebug -bool true
You might also check out the server logs:
/var/log/apache2 or /var/log/httpd
 
Also, I notice there was a place to get an error message in the omni preferences. I got this error:

The 127.0.0.1 server returned "bad gateway" (502) in response to a request to "MOVE /omnisync/OmniFocus.ofocus-copy-in-progress-pmBsCphTPqR"

Any thoughts on that?
 
Quote:
Originally Posted by kingsinger View Post
So I set up a local webdav server on OS X 10.4 using Manas' directions on his blog. It seems to be working. I can mount it locally with the finder and move a file into it or out of it. I can also mount it from a different computer, both on the LAN and over the internet in an SSH tunnel.

But when I tried to do an OF sync with it, it said that the sync had failed. And when I look in the WebDav volume, I see a folder with the following name:

OmniFocus.ofocus-copy-in-progress-kQxc0HuXvA8

Also, when I enter the webdav url into my browser, I get the following error:

"You don't have permission to access /omnisync/ on this server."

Any thoughts on this? I seem to remember somebody saying something about some extra sync logging you can turn on. But now I can't find that.

Could there still be some sort of a permissions problem I'm missing in the server config?

JL
It took me a while, but I finally remembered what the problem was that caused me to get the 502 error with my 10.4.11 setup last month. In your configuration file, you need to have a ServerName <name> directive that matches the hostname you are using in your address. The easiest thing to do is to use whatever your machine reports to the hostname command in the Terminal, which can also be gotten by looking at the Sharing preferences panel in System Preferences, right underneath the computer name. Update the configuration file to have that ServerName directive, restart the webserver, make sure you use the same name in your URL and it should work.
 
[beat me to it]
 
Although I managed to get this far, I'm really pretty limited on this terminal and config file editing stuff. Do you think you could perhaps spell out the specific code you stuck in the file with a concrete example for this dimbulb.

If I'm just using the LAN IP address as the host name, is that what I would use?

So for example, when I hit command K to open the dav volume I type in http://127.0.0.1/omnisync and it mounts. Or from a different machine on my LAN I enter http://hostIPaddress/omnisync.

Or do I need to insert the term I created in the Alias line of the dav config file? (i.e., omnisync).

TIA
 
Quote:
Originally Posted by kingsinger View Post
Although I managed to get this far, I'm really pretty limited on this terminal and config file editing stuff. Do you think you could perhaps spell out the specific code you stuck in the file with a concrete example for this dimbulb.

If I'm just using the LAN IP address as the host name, is that what I would use?

So for example, when I hit command K to open the dav volume I type in http://127.0.0.1/omnisync and it mounts. Or from a different machine on my LAN I enter http://hostIPaddress/omnisync.

Or do I need to insert the term I created in the Alias line of the dav config file? (i.e., omnisync).

TIA
Okay, the server name for my laptop is Bill-Palmers-Macbook.local, so I put ServerName Bill-Palmers-Macbook.local in the httpd.conf file. Your Mac and your iPhone already know how to do the conversion of that name to the local IP address on your LAN.

Code:
#
# ServerName allows you to set a host name which is sent back to clients for
# your server if it's different than the one the program would get (i.e., use
# "www" instead of the host's real name).
#
# Note: You cannot just invent host names and hope they work. The name you
# define here must be a valid DNS name for your host. If you don't understand
# this, ask your network administrator.
# If your host doesn't have a registered DNS name, enter its IP address here.
# You will have to access it by its address (e.g., http://123.45.67.89/)
# anyway, and this will make redirections work in a sensible way.
#
# 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your
# machine always knows itself by this address. If you use Apache strictly for
# local testing and development, you may use 127.0.0.1 as the server name.
#
#ServerName new.host.name
ServerName bill-palmers-macbook.local
Then I configure OmniFocus to use http://bill-palmers-macbook.local/webdav and I'm off to the races. My alias directive was:

Code:
Alias /webdav "/Library/WebServer/WebDAV"
The thing that dashes your hopes when it looks like the end is in sight is that you can mount a webdav volume without the servername bit being correct -- but then you'll get some 502 errors when you actually try to manipulate some files.
 
Okay. That worked to get it syncing on the LAN. But what about syncing remotely over the internet in an ssh tunnel?

I open up a tunnel to my dyndns server name, which then gets forwarded by my home router to the hard ip address I have set up on my home machine. Then I've got a port forward set up where port 8080 on my laptop forwards to port 80 on the remote desktop where the webdav share is.

I put the following url into omni's sync settings but it failed:

127.0.0.1:8080/omnisync

omnisync is the alias of my webdav share.

When I do use goliath or the finder this url takes me righ to the share and mounts it.

Is there anyway in the config file to let the webdav server know that server name equals either my computer name or the hard IP address for that computer? Or in the alternative, could I replace my computer name with the hard ip address for the computer in the server config file?

TIA for any additional thoughts on this. I'm halfway there. But it would be great to take it the rest of the way.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Careful with 4.0.2 and local webDAV blewis OmniFocus for iPhone 3 2010-08-16 02:41 PM
Using a local webdav-server to sync zikade Other WebDAV 3 2010-02-10 08:06 PM
Local network syncing... Juddbert OmniFocus 1 for Mac 5 2008-10-03 09:31 PM
local syncing? gravescp OmniFocus Syncing 1 2008-08-27 01:04 PM
1.02 - Local WebDav stopped working scottblackman Other WebDAV 28 2008-08-04 02:44 PM


All times are GMT -8. The time now is 02:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.