The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniWeb > OmniWeb Bug Reports
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
"view source" always reposts form data -- or not. Thread Tools Search this Thread Display Modes
If you fetch a page by submitting a form with the HTTP method POST, and then you try to refetch that page, OmniWeb runs a sheet warning you that to get the page again, it'll send the POST data again. So far, so good; I think this would be a bad feature in a mainstream browser as 99.8% of humanity aren't going to understand the question, but clearly OmniWeb isn't a mainstream browser.

If instead of cmd-R you do cmd-shift-V, you get the page source, without another roundtrip to the server. From my point of view this is good.

If you do cmd-I, then click on the outlineview item for the page source itself, then click view source, you always trigger a roundtrip to the server, without any warning sheet. I think this is bad, especially as I like OW's page inspector feature.

A site which can be used to display this behaviour is https://connect.apple.com/cgi-bin/We...MemberSite.woa. My apologies for the presence of the promotional picture of some old geezer on the first page after logging in -- it was while investigating said picture that I encountered the OW behaviour which I'm reporting.
 
Quote:
Originally Posted by leeharveyosmond
If you fetch a page by submitting a form with the HTTP method POST, and then you try to refetch that page, OmniWeb runs a sheet warning you that to get the page again, it'll send the POST data again. So far, so good; I think this would be a bad feature in a mainstream browser as 99.8% of humanity aren't going to understand the question, but clearly OmniWeb isn't a mainstream browser.
I just tried IE on Windows, Firefox and Safari. They all give a warning if they're reposting data.
 
Quote:
Originally Posted by Forrest
I just tried IE on Windows, Firefox and Safari. They all give a warning if they're reposting data.
I don't doubt for a moment that this is true. My complaint is that there are times when trying to view a page's source via the page inspector that OmniWeb won't show me the source for the page as rendered in the window, but instead makes a roundtrip to the server for a fresh copy, which can be bad when reposting data, and furthermore doesn't give any feedback that it's doing this.
 
Please submit this bug via send feedback...

We had to reimplement view source in general and also the whole page info and I guess we didn't reimplement view source quite the same in both places.

It's so annoying to have to redo stuff that used to work instead of being able to add cool new features, but at least we are more compatible. :rolleyes:
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't create PDF: "Failure when trying to produce data of type Apple PDF pasteboard" fjordaan OmniGraffle General 7 2011-11-24 01:13 PM
Creating an alternative "Palette" or drag source barorg OmniGraffle General 0 2011-10-28 12:13 PM
"Projects" view + "Contexts" view are slightly mis-named / misconceived RobTrew OmniFocus 1 for Mac 31 2007-08-23 07:19 PM


All times are GMT -8. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.