The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
New Version of OmniFocus Web Interface [Old Thread] Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Ok, to enable SSL in WEBrick, you must get the environment variable USE_SSL set to something ("true" works fine). There are multiple ways to skin this cat, but the simplest in my opinion would be to edit the file script/server and add this line after the first line which specifies the ruby interpreter:

ENV["USE_SSL"] = "true"

So, the file then looks like this:

#!/usr/bin/ruby
ENV["USE_SSL"] = "true"
require File.dirname(__FILE__) + '/../config/boot'
require 'commands/server'


The reason this works is because environment.rb will dynamically redefine the initialize method for the HTTP server to force SSL as long as ENV["USE_SSL"] evaluates to something.

Note that this will _still_ start WEBrick up on port 3000, and it is not a mixed-mode server, it will only support HTTPS at that point. Also it's using a locally-generated certificate, which your browser may require you to jump through some hoops to trust. Another thing, assuming you are port-forwarding, the host name of your NAT device and the hostname of your OmniFocus box are not likely to be the same. This means your browser will additionally complain about a name mismatch in the cert. You can fix this by changing a line near the end of config/environment.rb:

:SSLCertName => [ [ "CN", WEBrick::Utils::getservername ] ]

Replace the WEBrick::Utils::getservername bit with the DNS of your NAT device and this warning should go away.

If all of that is too complicated, you don't have to do it, just edit script/server as described at the top of this post and you'll probably be fine.

James

Last edited by jwaldrop; 2007-10-24 at 07:20 PM..
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus web interface amelchi OmniFocus 1 for Mac 3 2012-07-08 08:35 PM
Does OmniFocus show when something was completed? [A: Yes - see thread!] keypix OmniFocus 1 for Mac 3 2010-10-28 02:10 PM
OmniFocus for iPad interface feedback bnz OmniFocus for iPad 105 2010-07-12 02:49 AM
OmniFocus and Mac User Interface Conventions jashan OmniFocus 1 for Mac 9 2010-06-06 02:15 PM
OmniFocus Web Interface still running. How can I disable it? aaffleck OmniFocus 1 for Mac 7 2008-01-25 05:42 PM


All times are GMT -8. The time now is 01:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.