The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

"Unable to Save Change" When Checking of Item Thread Tools Search this Thread Display Modes

OmniFocus has suddenly started throwing an error when I attempt to check off an item, or create a new item, rendering it useless. Rebuilding the database hasn't solved the problem.

Some information you may find useful:

1. Operating system: Mac OSX 10.7.1.
2. OmniFocus version 1.9.3 (v77.75.11 r154845).
3. Omnifocus.ofocus directory permissions are 0755.
4. The attached ZIP contains a screen grab of the error message, and the relevant messages from the Console log.

Let me know if you need any further details.

Attached Files
File Type: zip (35.7 KB, 206 views)
An update on this: it appears to have fixed itself, somehow.

No amount of restarting OmniFocus, or even rebooting my Mac had any effect last night, but apparently leaving everything alone for about 10 hours did the trick just fine.

I have no idea what this issue was, but hopefully the details I posted in my original message will help you track down the underlying cause.

If you have any further questions, let me know; I'm still subscribed to this thread.

I've looked at the error message and the log; our code was calling the zip library's zipOpen() function to create a new zip file (within your OmniFocus.ofocus), but this was failing for some reason which unfortunately wasn't captured in the log.

Is it possible that your hard disk was full? Seems unlikely that you would have missed that as a reason, since the operating system probably have prompted you with some other alerts about that. But it's worth checking.

You mention that the POSIX permissions were set to 0755, but is there any chance the Access Control List or ownership on the file could have been set to the wrong thing? (This is pretty rare: we usually only see this right after someone migrates their account from another computer.)

If something like this ever happens again, please don't hesitate to call our support ninjas at 1-800-315-6664 (toll free in the US) or +1 206-523-4152 (International) on weekdays between 10am and 5pm (Pacific time), or to email for an expedited email response.
Hi Ken,

Thanks for the reply.

I migrated my account a couple of days ago, so that might have been what prompted the issue; I'd definitely used OmniFocus in the interim though, without any problems.

Whatever the root cause, it seems to be working fine now. I'll let you know if I run into any more problems.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Unable To Save Change" Error monooso OmniFocus 1 for Mac 2 2011-11-21 07:00 AM
'Unable to Save Change' when marking an item complete peterbaker OmniFocus 1 for Mac 0 2011-11-06 06:50 AM
Getting "Unable to save" error millerj OmniFocus 1 for Mac 1 2010-03-21 06:34 AM
"Unable to save" dialog fudster OmniFocus 1 for Mac 6 2009-09-01 10:13 AM
Unable to save change castleyt OmniFocus 1 for Mac 3 2008-11-04 09:54 AM

All times are GMT -8. The time now is 02:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.