The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

New Version of OmniFocus Web Interface [Old Thread] Thread Tools Search this Thread Display Modes
I can't get this to function any more. It worked fine, I logged out and logged back in, and now it's broken. When I try to load the page, the following appears in my Console log:

launchd[321]: com.omnigroup.omnifocus.web_interface: exited abnormally: Abort trap
launchd[321]: com.omnigroup.omnifocus.web_interface: 9 more failures without living at least 60 seconds will cause job removal

If I keep trying ruby eventually quits and restarts for some reason.
It prompted me for my password one when I restarted it, but now it just dies every time. I'm guessing the OF people broke it somehow.

Last edited by wealthychef; 2007-11-14 at 07:39 AM..
I rebooted and it fixed things. I'd love to know why. Rebooting is a PITA but if it works, great. I need my mobile contexts! Maybe I am foolish to rely on software for on-the-road urgent updates -- I'm going to have to start printing things just in case. Maybe printing is a better method anyway, but the web interface is very cool.
I have a strange bug - Web Interface forgets my login/password after a few days of use (maybe after reboot?), when I enter URL of web interface it just asks me password and even if I use correct one it asks again and again. Each time I have to roll back my Date Settings install older OF to Stop and Start Web Interface, set new password and change Date/OF version back to current - so please save my soul - let me know why it forgets my password.
Are you using the latest web interface? It sounds like you are not.
Having just bought a license for OmniFocus, I wanted to say thank you for your work on this. This makes OF infinitely better for me, as it allows me to access my lists through a web browser on Windows at work, and on my iPhone when I am away from my computers.

So thanks so much!
I just downloaded a copy of Omnifocus today and would love to get the Web Interface running since I am an iPhone user and away from my Mac during most of the day.

With the new version of the web interface still included, what steps do I need to follow in order to set this up? Has some sort of guide been written?

I likewise just want to say "thank you" ... the utility of OF skyrockets with this.
Problem with non English input while adding to Inbox:
entering something in Russian like
from FireFox, Safari, iPhone i get it messed up in my Inbox like this:
%u043F %u0440 %u043E %u0432 %u0435 %u0440 %u043A %u0430

(I added spaces so it doesn't convert codes)

Any ideas how to fix it?

2 wealthychef : Thanks for advice!
Originally Posted by Andrew Petrov View Post
When I try to run the server, I get the following error:

Last login: Tue Nov 13 00:03:54 on ttys001
/Users/G5/Library/Application\ Support/OmniFocus/Web\ Interface/script/server ; exit;
g5s-power-mac-g5:~ G5$ /Users/G5/Library/Application\ Support/OmniFocus/Web\ Interface/script/server ; exit;
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Ruby version is up-to-date; cgi_multipart_eof_fix was not loaded
!!! Path to log file not valid: log/mongrel.log
mongrel::start reported an error. Use mongrel_rails mongrel::start -h to get help.

[Process completed]

I have little terminal experience, so if you reply, please use simple instructions. Thank you very much for your help.
Andrew, you just need to switch to the "Web Interface" directory and then call "scripts/server". The Web Interface directory is the home for the rails app, and you have to start the execution from there--or the rails app can't find its bits and pieces to bootstrap itself.
I just downloaded the web interface package, changed the configurations, and then tried it from my local network. Wow. Thanks for all the hard work!

I'm so glad I didn't go through with my own GTD app. I had planned to do something almost exactly like this after hearing about all the cool Leopard APIs. Boy, would this have been a rude surprise ;-)

So, does anyone have a way to hide this all behind some SSL or security? I'm not too wild about letting the Web Interface be visible to the whole wild world of the internet.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus web interface amelchi OmniFocus 1 for Mac 3 2012-07-08 08:35 PM
Does OmniFocus show when something was completed? [A: Yes - see thread!] keypix OmniFocus 1 for Mac 3 2010-10-28 02:10 PM
OmniFocus for iPad interface feedback bnz OmniFocus for iPad 105 2010-07-12 02:49 AM
OmniFocus and Mac User Interface Conventions jashan OmniFocus 1 for Mac 9 2010-06-06 02:15 PM
OmniFocus Web Interface still running. How can I disable it? aaffleck OmniFocus 1 for Mac 7 2008-01-25 05:42 PM

All times are GMT -8. The time now is 03:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.