The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniFocus > OmniFocus 1 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Omnifocus Task Links not clickable in Evernote Thread Tools Search this Thread Display Modes
Putting Evernote links in Omnifocus works fine, but when I copy a task link from Omnifocus and paste it into an Evernote note, the link URL appears but it is not clickable and does not work.

However, if I copy the OF task link, then paste it into a task in OF, it is clickable. If I then copy the new clickable link and paste it into an EN note, it works!

The syntax of the link is exactly the same:
  • non working link - omnifocus:///task/n2l8S1mQaCw
  • working link - omnifocus:///task/n2l8S1mQaCw
So I don't know why I do the extra step of pasting it in OF first?


PS: I tried using Command-K Add Link in Evernote but it won't accept the URL as a link either.
 
Quote:
Originally Posted by Rockyroad View Post
Putting Evernote links in Omnifocus works fine, but when I copy a task link from Omnifocus and paste it into an Evernote note, the link URL appears but it is not clickable and does not work.

However, if I copy the OF task link, then paste it into a task in OF, it is clickable. If I then copy the new clickable link and paste it into an EN note, it works!

The syntax of the link is exactly the same:
  • non working link - omnifocus:///task/n2l8S1mQaCw
  • working link - omnifocus:///task/n2l8S1mQaCw
So I don't know why I do the extra step of pasting it in OF first?


PS: I tried using Command-K Add Link in Evernote but it won't accept the URL as a link either.
Doesn't work for me. Can I explain it in more details?
 
Quote:
Originally Posted by Rockyroad View Post
Putting Evernote links in Omnifocus works fine, but when I copy a task link from Omnifocus and paste it into an Evernote note, the link URL appears but it is not clickable and does not work. ...
Are you using Copy as Link from OF?
 
It's probably because OS X copies all the metadata and rich text of things as well - as plain text that link won't work, but when it's in OmniFocus it becomes rich text and thus has a link attached etc. Kinda like how you can copy bold, colours etc. out of windows and paste them into things (and why "Edit > Paste and Match Style" exists as a thing, to avoid pasting rich text).
 
It's very hit and miss which applications support this. The problem is that not all apps recognise the link as a URL. If the app/format supports explicitly marking it as a link (RTF, markdown etc.) then it seems more likely to work. I don't use Evernote myself but have had similar problems elsewhere.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -8. The time now is 05:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.