The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniGraffle > OmniGraffle General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Problem (bug?) with subtracting shapes Thread Tools Search this Thread Display Modes
I'm trying to subtract one custom shape from another. In this case, it is the 'eye' of a rabbit (where the rabbit is A and the eye is B):

Click for large view

When I try to subtract shapes, it doesn't work it just beeps, like it can't make that happen.

However, if I move the eye off to the side, so that it no look is completely inside the rabbit, like this:

Click for large view

then it works:
Click for large view

I've tried this on smaller custom shapes (with a dozen dots or two) and this is no problem at all. I can add lot's of 'holes' to a custom shape, and there is no issue.

Is there some sort of limit to the complexity, or is this a bug?
 
I just redid this with a 'cruder' rabbit:

Click for large view

and it seems to work.

Is there some limit on the number of points in the custom shape, or is there something else?
 
I'm going to try to 'add' points to the cruder rabbit and see what happens.

I have a sneaking suspicion that what is happening is that the shape gets 'corrupted' at some point, with a 'bad' point.

The reason I think this is that I've observed a handful of odd things:

1) sometimes when you try to add a point to a complex shape, the point does not appear under the mouse tip, but on another part of the drawing, usually the adjacent one.

2) when I subtract a small shape from a big shape (like the rabbit one shown here), I can get it to 'work' such that the result is only the 'eye'. Obviously, what I want is sort of the opposite I want the eye removed from the big shape but it seems like OmniGraffle is having trouble because the big shape (the 'rabbit' in this case) has some problem with its points.

3) one other thing happened when I tried to pull some points around, but it is too complicated to describe I'll get a screenshot when I see it again.
 
I submitted a 'feedback' from the OmniGraffle program and included a link this forum entry.
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible to have lines go AROUND shapes? Vandalfoe OmniGraffle General 0 2009-11-08 02:55 PM
Custom shapes in shapes inspector sunshine OmniGraffle General 4 2009-02-27 06:54 AM
3-D Shapes pbertain OmniGraffle Extras 1 2008-05-12 02:25 PM
3D-Shapes in OmniGraffle Pro 5? MacVDR OmniGraffle General 0 2008-03-11 01:06 AM
how can I do the Transparent in the shapes? lim71 OmniGraffle General 2 2006-10-06 05:18 AM


All times are GMT -8. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.