The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniOutliner > OmniOutliner 3 for Mac
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Summarize Field Issues Thread Tools Search this Thread Display Modes
I can't really use the Summary field option in OmniOutliner since every time I (accidentally) hit the TAB key, it wipes out all the data above that row.

I sent a support request and all I got back was "it's by design."

Great.

My point is the software should AT LEAST have an undo. Say you accidentally hit the TAB key and OO ("by design") deletes all your summarized data above that row -- you should be able to UN-TAB and have that data come back!

Apparently it's "by design" I have to re-enter all that data...

After having this happen 5 times, I've just moved my time keeping to Excel. Excel isn't as nice as OO, but it doesn't DELETE MY DATA (and it always gives me an un-do).

OO is great, perfect, for outlines, but trying to extend my uses of it, like for time keeping by task and sub-task, is proving to be an exercise in frustration.

If there were just an un-do feature to get my data back after an accidental TAB, I'd be OK with that.

-m

:(
 
What are you using for column type and summary type? I haven't managed to reproduce this problem, but maybe it only applies to certain combinations that I haven't tried. My test cases always gave me an Undo option which gave me the document state before the unwanted keypress.

Have you considered using the preference that controls the behavior of the Tab key? I'm guessing that your issue depends on Tab causing the row to be indented (hard to see how moving to a different cell could be an issue), right?

Are you doing a summary on the topic column?
 
This is how it happens for me.

Create a summary column (say the second column). I'm using numeric for summary column -- the second column, not the topic column.

Enter a row of data and a value for the number of hours (in this case).

Then hit ENTER to go to the next row. Hit TAB and the values above go away.

This happens to me regardless of what I try.

You can't reproduce this?

No undo.
 
Morkafur, are you saying that after these steps the Edit -> Undo function is unavailable? There's nothing at all to undo?
 
Quote:
Originally Posted by DerekM View Post
Morkafur, are you saying that after these steps the Edit -> Undo function is unavailable? There's nothing at all to undo?
This turned out to be my mistake. When I clicked TAB to (accidentally) create a new level indent, yes, my data above was gone. What I did was to SHIFT-TAB expecting the data to come back when I "un-indented". When that didn't work, I figured the data was gone.

However CMD-Z worked fine to bring the data back. I was confused thinking that if SHIFT-TAB to un-indent didn't work, then the data was gone for good.

Sorry for my confusion.

Thanks for all the great replies. :)

- m
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Notes Field Grewal69 OmniFocus 1 for Mac 0 2013-02-08 11:02 PM
Field Tab Order nickflorez OmniGraffle General 1 2008-09-08 10:59 AM
Purpose of the summarize button vamp07 OmniWeb General 3 2007-10-29 03:13 AM
Shift-tab not hooked up between search field and location field. urbanape OmniWeb General 1 2006-08-03 09:36 AM
Using Shift+Tab does not move focus from Search Field to Address Field jashugan OmniWeb Bug Reports 3 2006-05-30 11:54 AM


All times are GMT -8. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.