The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > OmniPlan > OmniPlan General
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Help Beachball on Launch - a new thing Thread Tools Search this Thread Display Modes

Yesterday it worked -- today it dies. When I try to start OmniPlan the text in the menubar appears and then I go straight to the spinning beachball of death! I assume something got munched in prefs file and trashed it but to no avail, are there some other files I should clean out?

I am starting it by double clicking the application itself it that matters.

This is not really a bug report, I file very detailed reports through appropriate channels when I can isolate something, but rather a plea for help in the darkness.

Well Piffle!

It works again today, there must be something extra going on but I can't really say I will keep trying to isolate this...
Now you've got me curious...

Did you have the same internet access both times? (OmniPlan does check in with our server periodically to ensure you're running the latest version, unless you turn that option off.)

If it gets stuck again, take a sample of it before force-quitting and send us the sample. We might be able to pull something from that.
To take a sample:
1) Open Activity Monitor (in Applications/Utilities)
2) Select the stuck OmniPlan process from the list
3) Click "Inspect" in the toolbar; a new window will appear
4) Click the "Sample" button in the new window (and wait several seconds)
5) When it finishes, click "Save..." and save the file somewhere you can find it again
6) Attach the file to an email and send it to
This is on a laptop and my network connection changes between home and the office. I had thought about the network check but I did have connectivity at the time and I waited for 5 or so minutes long enough for any messed up connections to have timed out I would think.

Funny thing is that I tried to sample OmniPlan when this happened [in a sick sort of way I like bugs ;-) ] and the sample came up empty. So I assume that you were blocking in a system call some way. I did not go any further in diagnosing that, I will fire up ktrace if it happens again and let you know where things were blocking.
I've been using OmniPlan almost daily since the beta was released. Go figure. Just when I started relying on it (I know, I know...not safe).

So I tried to open a project plan I had on my hard drive, and it opens, but then freezes, and the beach ball spins, as though it's loading up the file. No luck. Force quit. I thought maybe I had over-loaded the CPU. I was also running XP on Parallels at the time, with 6-7 apps open on OS X.

But then tonight, I tried to open OmniPlan by itself, with nothing else open. It froze. This time I tried just opening the program alone, not a document. I restarted, just to be sure. Same thing. Couldn't email for support on the Help Menu, because the beach ball is spinning. So I looked this up via Safari.

I read the posts below, and I also have changed network settings a lot. I have a work wireless network I use, and a home wireless network, as well as ethernet networks at client sites that I use. But I don't see what these have to do with OmniPlan. The closest it gets to network activity is emailing MPP plans back and forth.

Wait a minute. I changed something in my Parallels settings to share the network connection between XP and OS X. I don't know what that would do, but that's the same time of day OmniPlan quit working. I will check on this and report.
1) you can send an email to directly if you can't launch OmniPlan. Just describe your problem and mention which build you're running (probably beta 6). In this specific case, including a sample report (as described above) would be very helpful.

2) Try deleting your OmniPlan preferences file before launching. If you have OmniPlan preferences set to re-open files you had open last time, it could be getting stuck trying to open one of those files.

3) The only reason I mention the network connection is because OmniPlan (like all our apps) does check your local network for other copies of OmniPlan running to make sure you're obeying the licensing. It also checks in with our server (if you have auto-check for update enabled) to make sure you're running the latest build. Both of these actions occur fairly early in the launch process, so if your network access is in a funny state, it might be confusing OmniPlan.
This is a long shot, but are any of you running on an Intel-based Mac?

If so, could you "get info" on OmniPlan and see if "open with Rosetta" is checked? It shouldn't be checked.
I got the endless beach-ball at launch yesterday as well. If you are patient, let OmniPlan just sit and do it's thing. I did this and it took OmniPlan 8+ minutes to load up my project file. In the meantime, in Activity Monitor, OmniPlan took 100% of my Core Duo processors, displayed in red as Not Responding and ate up over 600MB of free RAM. It ate up the RAM gradually over the course of the 8 minutes.

But when the program finally came back to life, my file was intact. I exported a couple of backups of it in CSV and OmniOutliner formats.

Aaron at OmniGroup confirmed that with the latest internal build, it opened fine (I sent my file). So now I just have to wait with the rest of you. (And it happened at a point where I started relying on OmniPlan as well.)

OK - back again, a day later. In the meantime, I have downloaded the latest build (6b) and replaced the version in my Applications folder. That didn't really seem to work.

I also tried shutting down all network sharing, and shutting off any network connections, just to be safe (this was all before I got your last steps of advice, Lizard.)

So after deleting the omniplan preferences file in Libarary/Preferences, OmniPlan opens perfectly, launching a fresh plan with task 1 just staring at me. I also tried opening some of the OmniPlan and MPP files I had on my hard drive, and they opened instantly and cleanly. Thanks.

To answer the question, yes, I'm running an (Intel) MacBook 2.0 Ghz with 1.25 GB RAM. I also did try the waiting thing, but that's no fun. Because hey, in the immortal words of Tommy Lee, "we're not here for a long time, we're here for a good time."

I don't know what caused the crash. Maybe a plan that was too big. Maybe a combination of fast-switching between apps. But it appears, for now, that this problem can be cured by deleting the Preferences file from the Library. Thanks Omni.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
BeachBall on Save BoC OmniOutliner 3 for Mac 1 2009-12-11 10:58 AM
OG need 5 s for save and beachball jochen OmniGraffle General 5 2008-04-29 01:08 AM
beachball on ChadCN OmniWeb Bug Reports 2 2008-03-19 01:44 PM
Beachball of Doom Banagor OmniWeb Bug Reports 12 2007-10-12 04:59 PM
Beachball after startup... but why? Vincent OmniWeb General 1 2007-03-13 02:32 PM

All times are GMT -8. The time now is 08:06 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.