The Omni Group
These forums are now read-only. Please visit our new forums to participate in discussion. A new account will be required to post in the new forums. For more info on the switch, see this post. Thank you!

Go Back   The Omni Group Forums > Developer > Omni Frameworks
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
Not working after importing the framework in the project Thread Tools Search this Thread Display Modes
Hello, I have downloaded the framework, and I see it has pretty nice things, one of the things Im interested in is parse an NSAttributedString to an html-like string with the tags, the functionality that implements its the one I need.
BUT, I installed the frameworks, then I add them into my project, and in the target I add a new copy files build phase with resource Frameworks, then I drag and drop the framework (already add it into the project) to the copy link inside the target... so OK I compile.. all fine.. I do the following to make a test:.
<code>
NSMutableParagraphStyle * aMutableParagraphStyle = [[(NSTextView *)[self view] typingAttributes]
objectForKey:@"NSParagraphStyle"];


NSMutableAttributedString * a = [[NSMutableAttributedString alloc] initWithString:text];
[a addAttribute:NSParagraphStyleAttributeName
value:aMutableParagraphStyle
range:NSRangeFromString(text)];

[aMutableParagraphStyle release];
[a autorelease];
NSString * a2 = [a htmlString];
</code>
but then I in console when running,
-[NSConcreteMutableAttributedString htmlString]: unrecognized selector sent to instance 0x26a8f0
Any ideas what I missed... ? Im new to this FW, and to using 3rd parties code in my projects, so please be kind with me.. Thanks

Best regards
Gustavo
 
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
OmniFocus Creates Duplicate Contexts when importing OmniOutliner project templates shanekeller OmniFocus 1 for Mac 1 2013-03-03 08:35 PM
@Project Title@ Working in 2.2.1 ? reeldba OmniPlan Extras 0 2012-10-12 05:12 AM
Importing from MS Project issue leafy OmniPlan General 1 2010-06-24 01:02 AM
Trouble Importing mpp from MS Project Manager nerea OmniPlan Extras 5 2009-11-01 08:14 AM
More problems working with MS Project sabeke OmniPlan General 3 2009-01-19 01:20 AM


All times are GMT -8. The time now is 11:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.